irssi.mk 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. ################################################################################
  2. #
  3. # irssi
  4. #
  5. ################################################################################
  6. IRSSI_VERSION = 1.0.8
  7. IRSSI_SOURCE = irssi-$(IRSSI_VERSION).tar.xz
  8. # Do not use the github helper here. The generated tarball is *NOT* the
  9. # same as the one uploaded by upstream for the release.
  10. IRSSI_SITE = https://github.com/irssi/irssi/releases/download/$(IRSSI_VERSION)
  11. IRSSI_LICENSE = GPL-2.0+
  12. IRSSI_LICENSE_FILES = COPYING
  13. IRSSI_DEPENDENCIES = host-pkgconf libglib2 ncurses openssl
  14. IRSSI_CONF_OPTS = \
  15. --disable-glibtest \
  16. --without-perl
  17. ifeq ($(BR2_PACKAGE_IRSSI_PROXY),y)
  18. IRSSI_CONF_OPTS += --with-proxy
  19. # If shared libs are disabled, 'proxy' has to go in the list of built-in
  20. # modules.
  21. ifeq ($(BR2_STATIC_LIBS),y)
  22. IRSSI_CONF_OPTS += --with-modules=proxy
  23. endif
  24. else
  25. IRSSI_CONF_OPTS += --without-proxy
  26. endif # proxy
  27. ifeq ($(BR2_PACKAGE_IRSSI_TRUE_COLOR),y)
  28. IRSSI_CONF_OPTS += --enable-true-color
  29. else
  30. IRSSI_CONF_OPTS += --disable-true-color
  31. endif
  32. # Cross-compiling irssi with the perl interpreter enabled doesn't work
  33. # yet. So, remove scripts as they are useless in that case.
  34. define IRSSI_REMOVE_SCRIPTS
  35. rm -rf $(TARGET_DIR)/usr/share/irssi/scripts/
  36. endef
  37. IRSSI_POST_INSTALL_TARGET_HOOKS += IRSSI_REMOVE_SCRIPTS
  38. $(eval $(autotools-package))