ipmitool.mk 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. ################################################################################
  2. #
  3. # ipmitool
  4. #
  5. ################################################################################
  6. IPMITOOL_VERSION = 1.8.18
  7. IPMITOOL_SOURCE = ipmitool-$(IPMITOOL_VERSION).tar.bz2
  8. IPMITOOL_SITE = http://downloads.sourceforge.net/project/ipmitool/ipmitool/$(IPMITOOL_VERSION)
  9. IPMITOOL_LICENSE = BSD-3-Clause
  10. IPMITOOL_LICENSE_FILES = COPYING
  11. # 0008-fru-Fix-buffer-overflow-vulnerabilities.patch
  12. # 0009-fru-Fix-buffer-overflow-in-ipmi_spd_print_fru.patch
  13. # 0010-session-Fix-buffer-overflow-in-ipmi_get_session_info.patch
  14. # 0011-channel-Fix-buffer-overflow.patch
  15. # 0012-lanp-Fix-buffer-overflows-in-get_lan_param_select.patch
  16. # 0013-fru-sdr-Fix-id_string-buffer-overflows.patch
  17. IPMITOOL_IGNORE_CVES += CVE-2020-5208
  18. ifeq ($(BR2_PACKAGE_IPMITOOL_LANPLUS),y)
  19. IPMITOOL_DEPENDENCIES += openssl
  20. IPMITOOL_CONF_OPTS += --enable-intf-lanplus
  21. else
  22. IPMITOOL_CONF_OPTS += --disable-intf-lanplus
  23. endif
  24. ifeq ($(BR2_PACKAGE_IPMITOOL_USB),y)
  25. IPMITOOL_CONF_OPTS += --enable-intf-usb
  26. else
  27. IPMITOOL_CONF_OPTS += --disable-intf-usb
  28. endif
  29. ifeq ($(BR2_PACKAGE_IPMITOOL_IPMISHELL),y)
  30. IPMITOOL_DEPENDENCIES += ncurses readline
  31. IPMITOOL_CONF_OPTS += --enable-ipmishell
  32. else
  33. IPMITOOL_CONF_OPTS += --disable-ipmishell
  34. endif
  35. ifeq ($(BR2_PACKAGE_IPMITOOL_IPMIEVD),)
  36. define IPMITOOL_REMOVE_IPMIEVD
  37. $(RM) -f $(TARGET_DIR)/usr/sbin/ipmievd
  38. endef
  39. IPMITOOL_POST_INSTALL_TARGET_HOOKS += IPMITOOL_REMOVE_IPMIEVD
  40. endif
  41. $(eval $(autotools-package))