iozone.mk 944 B

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # iozone
  4. #
  5. ################################################################################
  6. IOZONE_VERSION = 3_489
  7. IOZONE_SOURCE = iozone$(IOZONE_VERSION).tar
  8. IOZONE_SITE = http://www.iozone.org/src/current
  9. IOZONE_LICENSE = IOzone license (NO DERIVED WORKS ALLOWED)
  10. # IOzone license details can be found at:
  11. # http://www.iozone.org/docs/Iozone_License.txt
  12. # AIO support not available on uClibc, use the linux (non-aio) target.
  13. ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
  14. IOZONE_TARGET = linux-noaio
  15. else
  16. IOZONE_TARGET = linux
  17. endif
  18. define IOZONE_BUILD_CMDS
  19. $(MAKE) $(TARGET_CONFIGURE_OPTS) $(IOZONE_TARGET) -C $(@D)/src/current
  20. endef
  21. define IOZONE_INSTALL_TARGET_CMDS
  22. $(INSTALL) -D -m 755 $(@D)/src/current/iozone \
  23. $(TARGET_DIR)/usr/bin/iozone
  24. $(INSTALL) -D -m 755 $(@D)/src/current/fileop \
  25. $(TARGET_DIR)/usr/bin/fileop
  26. endef
  27. $(eval $(generic-package))