iostat.mk 563 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # iostat
  4. #
  5. ################################################################################
  6. IOSTAT_VERSION = 2.2
  7. IOSTAT_SITE = http://linuxinsight.com/sites/default/files
  8. IOSTAT_LICENSE = GPL
  9. IOSTAT_LICENSE_FILES = LICENSE
  10. define IOSTAT_BUILD_CMDS
  11. $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
  12. CFLAGS="$(TARGET_CFLAGS) -DHZ=100"
  13. endef
  14. define IOSTAT_INSTALL_TARGET_CMDS
  15. $(INSTALL) -D -m 0755 $(IOSTAT_DIR)/iostat $(TARGET_DIR)/usr/bin/iostat
  16. endef
  17. $(eval $(generic-package))