iodine.mk 966 B

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # iodine
  4. #
  5. ################################################################################
  6. IODINE_VERSION = 0.7.0
  7. IODINE_SITE = http://code.kryo.se/iodine
  8. IODINE_DEPENDENCIES = zlib
  9. IODINE_LICENSE = MIT
  10. IODINE_LICENSE_FILES = README
  11. IODINE_CFLAGS = $(TARGET_CFLAGS)
  12. # iodine contains a local implementation of daemon(3) for older
  13. # systems, unless __GLIBC__ is defined. Musl does provide it, but
  14. # unlike uClibc it doesn't define __GLIBC__. Work around it by
  15. # pretending to be glibc as we otherwise end up with symbol conflicts.
  16. ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
  17. IODINE_CFLAGS += -D__GLIBC__
  18. endif
  19. define IODINE_BUILD_CMDS
  20. $(TARGET_CONFIGURE_OPTS) CFLAGS="$(IODINE_CFLAGS)" \
  21. $(MAKE) ARCH=$(BR2_ARCH) -C $(@D)
  22. endef
  23. define IODINE_INSTALL_TARGET_CMDS
  24. $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) install DESTDIR="$(TARGET_DIR)" prefix=/usr
  25. endef
  26. $(eval $(generic-package))