input-event-daemon.mk 1.2 KB

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # input-event-daemon
  4. #
  5. ################################################################################
  6. INPUT_EVENT_DAEMON_VERSION = 0.1.3
  7. INPUT_EVENT_DAEMON_SITE = $(call github,gandro,input-event-daemon,v$(INPUT_EVENT_DAEMON_VERSION))
  8. INPUT_EVENT_DAEMON_LICENSE = input-event-daemon license
  9. INPUT_EVENT_DAEMON_LICENSE_FILES = README
  10. define INPUT_EVENT_DAEMON_BUILD_CMDS
  11. touch $(@D)/input-event-table.h
  12. $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
  13. LDFLAGS="$(TARGET_LDFLAGS)" -C $(@D)
  14. endef
  15. define INPUT_EVENT_DAEMON_INSTALL_TARGET_CMDS
  16. $(INSTALL) -m 755 -D $(@D)/input-event-daemon \
  17. $(TARGET_DIR)/usr/bin/input-event-daemon
  18. $(INSTALL) -m 644 -D $(@D)/docs/sample.conf \
  19. $(TARGET_DIR)/etc/input-event-daemon.conf
  20. endef
  21. define INPUT_EVENT_DAEMON_INSTALL_INIT_SYSV
  22. $(INSTALL) -m 0755 -D package/input-event-daemon/S99input-event-daemon \
  23. $(TARGET_DIR)/etc/init.d/S99input-event-daemon
  24. endef
  25. define INPUT_EVENT_DAEMON_INSTALL_INIT_SYSTEMD
  26. $(INSTALL) -D -m 644 package/input-event-daemon/input-event-daemon.service \
  27. $(TARGET_DIR)/usr/lib/systemd/system/input-event-daemon.service
  28. endef
  29. $(eval $(generic-package))