ima-evm-utils.mk 1.1 KB

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # ima-evm-utils
  4. #
  5. ################################################################################
  6. IMA_EVM_UTILS_VERSION = 1.3.2
  7. IMA_EVM_UTILS_SITE = http://downloads.sourceforge.net/project/linux-ima/ima-evm-utils
  8. IMA_EVM_UTILS_LICENSE = GPL-2.0
  9. IMA_EVM_UTILS_LICENSE_FILES = COPYING
  10. IMA_EVM_UTILS_DEPENDENCIES = host-pkgconf keyutils openssl tpm2-tss
  11. # Tarball doesn't contain configure
  12. IMA_EVM_UTILS_AUTORECONF = YES
  13. # Build and install in the src subdirectory. This avoids building the
  14. # documentation, which requires asciidoc and xsltproc. Note that configure still
  15. # needs to be run from the top dir, so _SUBDIR can't be used.
  16. define IMA_EVM_UTILS_BUILD_CMDS
  17. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src all
  18. endef
  19. define IMA_EVM_UTILS_INSTALL_STAGING_CMDS
  20. $(TARGET_MAKE_ENV) $(MAKE) DESTDIR="$(STAGING_DIR)" -C $(@D)/src install
  21. endef
  22. define IMA_EVM_UTILS_INSTALL_TARGET_CMDS
  23. $(TARGET_MAKE_ENV) $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D)/src install
  24. endef
  25. $(eval $(autotools-package))