ifplugd.mk 1.2 KB

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # ifplugd
  4. #
  5. ################################################################################
  6. IFPLUGD_VERSION = 0.28
  7. IFPLUGD_SITE = http://0pointer.de/lennart/projects/ifplugd
  8. IFPLUGD_LICENSE = GPL-2.0+
  9. IFPLUGD_LICENSE_FILES = LICENSE
  10. IFPLUGD_AUTORECONF = YES
  11. # install-strip unconditionally overwrites $(TARGET_DIR)/etc/ifplugd/ifplugd.*
  12. IFPLUGD_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-exec
  13. IFPLUGD_CONF_OPTS = --disable-lynx --with-initdir=/etc/init.d/
  14. IFPLUGD_DEPENDENCIES = libdaemon
  15. define IFPLUGD_INSTALL_FIXUP
  16. $(INSTALL) -D -m 0644 $(@D)/conf/ifplugd.conf $(TARGET_DIR)/etc/ifplugd/ifplugd.conf; \
  17. $(SED) 's^\(ARGS=.*\)w^\1^' $(TARGET_DIR)/etc/ifplugd/ifplugd.conf; \
  18. $(INSTALL) -D -m 0755 $(@D)/conf/ifplugd.action \
  19. $(TARGET_DIR)/etc/ifplugd/ifplugd.action
  20. endef
  21. IFPLUGD_POST_INSTALL_TARGET_HOOKS += IFPLUGD_INSTALL_FIXUP
  22. define IFPLUGD_INSTALL_INIT_SYSV
  23. $(INSTALL) -D -m 0755 $(@D)/conf/ifplugd.init \
  24. $(TARGET_DIR)/etc/init.d/S45ifplugd
  25. # don't use bash for init script
  26. $(SED) 's^/bin/bash^/bin/sh^g' $(TARGET_DIR)/etc/init.d/S45ifplugd
  27. endef
  28. $(eval $(autotools-package))