ibrdtnd.mk 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. ################################################################################
  2. #
  3. # ibrdtnd
  4. #
  5. ################################################################################
  6. IBRDTND_VERSION = 1.0.1
  7. IBRDTND_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
  8. IBRDTND_LICENSE = Apache-2.0
  9. IBRDTND_LICENSE_FILES = COPYING
  10. IBRDTND_DEPENDENCIES = ibrdtn ibrcommon host-pkgconf
  11. # Disable features that don't have the necessary dependencies in
  12. # Buildroot
  13. IBRDTND_CONF_OPTS = \
  14. --disable-dtndht \
  15. --without-wifip2p \
  16. --without-vmime
  17. # don't build documentation
  18. IBRDTND_CONF_ENV = PDFLATEX='no'
  19. ifeq ($(BR2_PACKAGE_LIBDAEMON),y)
  20. IBRDTND_CONF_OPTS += --enable-libdaemon
  21. IBRDTND_DEPENDENCIES += libdaemon
  22. else
  23. IBRDTND_CONF_OPTS += --disable-libdaemon
  24. endif
  25. ifeq ($(BR2_PACKAGE_LIBCURL),y)
  26. IBRDTND_CONF_OPTS += --with-curl
  27. IBRDTND_DEPENDENCIES += libcurl
  28. else
  29. IBRDTND_CONF_OPTS += --without-curl
  30. endif
  31. ifeq ($(BR2_PACKAGE_SQLITE),y)
  32. IBRDTND_CONF_OPTS += --with-sqlite
  33. IBRDTND_DEPENDENCIES += sqlite
  34. else
  35. IBRDTND_CONF_OPTS += --without-sqlite
  36. endif
  37. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  38. IBRDTND_CONF_OPTS += --with-tls
  39. IBRDTND_DEPENDENCIES += openssl
  40. else
  41. IBRDTND_CONF_OPTS += --without-tls
  42. endif
  43. $(eval $(autotools-package))