ibrcommon.mk 905 B

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # ibrcommon
  4. #
  5. ################################################################################
  6. IBRCOMMON_VERSION = 1.0.1
  7. IBRCOMMON_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
  8. IBRCOMMON_INSTALL_STAGING = YES
  9. IBRCOMMON_LICENSE = Apache-2.0
  10. IBRCOMMON_LICENSE_FILES = COPYING README
  11. IBRCOMMON_DEPENDENCIES = host-pkgconf
  12. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  13. IBRCOMMON_DEPENDENCIES += openssl
  14. IBRCOMMON_CONF_OPTS += --with-openssl
  15. else
  16. IBRCOMMON_CONF_OPTS += --without-openssl
  17. endif
  18. ifeq ($(BR2_PACKAGE_LIBNL),y)
  19. IBRCOMMON_DEPENDENCIES += libnl
  20. IBRCOMMON_CONF_OPTS += --with-lowpan
  21. else
  22. IBRCOMMON_CONF_OPTS += --without-lowpan
  23. endif
  24. ifeq ($(BR2_PACKAGE_LIBXML2),y)
  25. IBRCOMMON_DEPENDENCIES += libxml2
  26. IBRCOMMON_CONF_OPTS += --with-xml
  27. else
  28. IBRCOMMON_CONF_OPTS += --without-xml
  29. endif
  30. $(eval $(autotools-package))