htop.mk 895 B

12345678910111213141516171819202122232425262728
  1. ################################################################################
  2. #
  3. # htop
  4. #
  5. ################################################################################
  6. HTOP_VERSION = 3.0.2
  7. HTOP_SITE = https://dl.bintray.com/htop/source
  8. HTOP_DEPENDENCIES = ncurses
  9. # Prevent htop build system from searching the host paths
  10. HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
  11. HTOP_LICENSE = GPL-2.0
  12. HTOP_LICENSE_FILES = COPYING
  13. ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
  14. HTOP_CONF_OPTS += --enable-unicode
  15. else
  16. HTOP_CONF_OPTS += --disable-unicode
  17. endif
  18. # ARC uses an old uClibc that needs dladdr() for backtrace support,
  19. # which doesn't work for static only scenario, so as a workaround, we
  20. # pretend that execinfo.h is not available.
  21. ifeq ($(BR2_arc)$(BR2_STATIC_LIBS),yy)
  22. HTOP_CONF_ENV += ac_cv_header_execinfo_h=no
  23. endif
  24. $(eval $(autotools-package))