gzip.mk 1022 B

12345678910111213141516171819202122232425
  1. ################################################################################
  2. #
  3. # gzip
  4. #
  5. ################################################################################
  6. GZIP_VERSION = 1.10
  7. GZIP_SOURCE = gzip-$(GZIP_VERSION).tar.xz
  8. GZIP_SITE = $(BR2_GNU_MIRROR)/gzip
  9. # Some other tools expect it to be in /bin
  10. GZIP_CONF_OPTS = --exec-prefix=/
  11. GZIP_LICENSE = GPL-3.0+
  12. GZIP_LICENSE_FILES = COPYING
  13. GZIP_CONF_ENV += gl_cv_func_fflush_stdin=yes
  14. HOST_GZIP_CONF_ENV += gl_cv_func_fflush_stdin=yes
  15. # configure substitutes $(SHELL) for the shell shebang in scripts like
  16. # gzexe. Unfortunately, the same $(SHELL) variable will also be used by
  17. # make to run its commands. Fortunately, /bin/sh is always a POSIX shell
  18. # on both the target and host systems that we support. Even with this,
  19. # the configure check is slightly broken and prints a bogus warning:
  20. # "using /bin/sh, even though it may have file descriptor bugs"
  21. GZIP_CONF_ENV += ac_cv_path_shell=/bin/sh
  22. $(eval $(autotools-package))
  23. $(eval $(host-autotools-package))