gtk2-engines.mk 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. ################################################################################
  2. #
  3. # gtk2-engines
  4. #
  5. ################################################################################
  6. GTK2_ENGINES_VERSION_MAJOR = 2.20
  7. GTK2_ENGINES_VERSION = $(GTK2_ENGINES_VERSION_MAJOR).2
  8. GTK2_ENGINES_SOURCE = gtk-engines-$(GTK2_ENGINES_VERSION).tar.bz2
  9. GTK2_ENGINES_SITE = http://ftp.gnome.org/pub/GNOME/sources/gtk-engines/$(GTK2_ENGINES_VERSION_MAJOR)
  10. GTK2_ENGINES_DEPENDENCIES = libgtk2 host-intltool
  11. GTK2_ENGINES_LICENSE = LGPL-2.1+
  12. GTK2_ENGINES_LICENSE_FILES = COPYING
  13. GTK2_ENGINES_CONF_ENV = \
  14. ac_cv_func_posix_getpwuid_r=yes \
  15. glib_cv_stack_grows=no \
  16. glib_cv_uscore=no \
  17. ac_cv_func_strtod=yes \
  18. ac_fsusage_space=yes \
  19. fu_cv_sys_stat_statfs2_bsize=yes \
  20. ac_cv_func_closedir_void=no \
  21. ac_cv_func_getloadavg=no \
  22. ac_cv_lib_util_getloadavg=no \
  23. ac_cv_lib_getloadavg_getloadavg=no \
  24. ac_cv_func_getgroups=yes \
  25. ac_cv_func_getgroups_works=yes \
  26. ac_cv_func_chown_works=yes \
  27. ac_cv_have_decl_euidaccess=no \
  28. ac_cv_func_euidaccess=no \
  29. ac_cv_have_decl_strnlen=yes \
  30. ac_cv_func_strnlen_working=yes \
  31. ac_cv_func_lstat_dereferences_slashed_symlink=yes \
  32. ac_cv_func_lstat_empty_string_bug=no \
  33. ac_cv_func_stat_empty_string_bug=no \
  34. vb_cv_func_rename_trailing_slash_bug=no \
  35. ac_cv_have_decl_nanosleep=yes \
  36. jm_cv_func_nanosleep_works=yes \
  37. gl_cv_func_working_utimes=yes \
  38. ac_cv_func_utime_null=yes \
  39. ac_cv_have_decl_strerror_r=yes \
  40. ac_cv_func_strerror_r_char_p=no \
  41. jm_cv_func_svid_putenv=yes \
  42. ac_cv_func_getcwd_null=yes \
  43. ac_cv_func_getdelim=yes \
  44. ac_cv_func_mkstemp=yes \
  45. utils_cv_func_mkstemp_limitations=no \
  46. utils_cv_func_mkdir_trailing_slash_bug=no \
  47. jm_cv_func_gettimeofday_clobber=no \
  48. gl_cv_func_working_readdir=yes \
  49. jm_ac_cv_func_link_follows_symlink=no \
  50. utils_cv_localtime_cache=no \
  51. ac_cv_struct_st_mtim_nsec=no \
  52. gl_cv_func_tzset_clobber=no \
  53. gl_cv_func_getcwd_null=yes \
  54. gl_cv_func_getcwd_path_max=yes \
  55. ac_cv_func_fnmatch_gnu=yes \
  56. am_getline_needs_run_time_check=no \
  57. am_cv_func_working_getline=yes \
  58. gl_cv_func_mkdir_trailing_slash_bug=no \
  59. gl_cv_func_mkstemp_limitations=no \
  60. ac_cv_func_working_mktime=yes \
  61. jm_cv_func_working_re_compile_pattern=yes \
  62. ac_use_included_regex=no \
  63. gl_cv_c_restrict=no \
  64. ac_cv_path_CUPS_CONFIG=no
  65. GTK2_ENGINES_CONF_OPTS = \
  66. --with-x \
  67. --x-includes=$(STAGING_DIR)/usr/include/X11 \
  68. --x-libraries=$(STAGING_DIR)/usr/lib \
  69. --disable-glibtest \
  70. --enable-explicit-deps=no \
  71. --enable-clearlooks \
  72. --disable-crux \
  73. --disable-hc \
  74. --disable-industrial \
  75. --disable-mist \
  76. --disable-redmond \
  77. --disable-smooth \
  78. --disable-glide \
  79. --disable-thinice \
  80. --enable-animation \
  81. --disable-development \
  82. --disable-paranoia \
  83. --disable-deprecated
  84. $(eval $(autotools-package))