gnuplot.mk 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. ################################################################################
  2. #
  3. # gnuplot
  4. #
  5. ################################################################################
  6. GNUPLOT_VERSION = 5.4.1
  7. GNUPLOT_SITE = http://downloads.sourceforge.net/project/gnuplot/gnuplot/$(GNUPLOT_VERSION)
  8. GNUPLOT_LICENSE = gnuplot license (open source)
  9. GNUPLOT_LICENSE_FILES = Copyright
  10. GNUPLOT_AUTORECONF = YES
  11. GNUPLOT_CONF_OPTS = \
  12. --without-x \
  13. --disable-raise-console \
  14. --disable-mouse \
  15. --without-tutorial \
  16. --disable-demo \
  17. --without-row-help \
  18. --disable-history-file \
  19. --disable-wxwidgets \
  20. --without-lua \
  21. --without-latex \
  22. --without-cairo
  23. # relocation truncated to fit: R_68K_GOT16O
  24. ifeq ($(BR2_m68k_cf),y)
  25. GNUPLOT_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
  26. endif
  27. ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
  28. GNUPLOT_CONF_OPTS += --with-gd
  29. GNUPLOT_DEPENDENCIES += gd
  30. GNUPLOT_CONF_ENV += \
  31. ac_cv_path_GDLIB_CONFIG=$(STAGING_DIR)/usr/bin/gdlib-config
  32. else
  33. GNUPLOT_CONF_OPTS += --without-gd
  34. endif
  35. ifeq ($(BR2_PACKAGE_READLINE),y)
  36. GNUPLOT_CONF_OPTS += --with-readline=gnu
  37. GNUPLOT_DEPENDENCIES += readline
  38. else
  39. GNUPLOT_CONF_OPTS += --without-readline
  40. endif
  41. # Remove Javascript scripts, lua scripts, PostScript files
  42. define GNUPLOT_REMOVE_UNNEEDED_FILES
  43. $(RM) -rf $(TARGET_DIR)/usr/share/gnuplot
  44. endef
  45. GNUPLOT_POST_INSTALL_TARGET_HOOKS += GNUPLOT_REMOVE_UNNEEDED_FILES
  46. $(eval $(autotools-package))