gmp.mk 864 B

1234567891011121314151617181920212223242526272829
  1. ################################################################################
  2. #
  3. # gmp
  4. #
  5. ################################################################################
  6. GMP_VERSION = 6.1.2
  7. GMP_SITE = $(BR2_GNU_MIRROR)/gmp
  8. GMP_SOURCE = gmp-$(GMP_VERSION).tar.xz
  9. GMP_INSTALL_STAGING = YES
  10. GMP_LICENSE = LGPL-3.0+ or GPL-2.0+
  11. GMP_LICENSE_FILES = COPYING.LESSERv3 COPYINGv2
  12. GMP_DEPENDENCIES = host-m4
  13. HOST_GMP_DEPENDENCIES = host-m4
  14. # GMP doesn't support assembly for coldfire or mips r6 ISA yet
  15. # Disable for ARM v7m since it has different asm constraints
  16. ifeq ($(BR2_m68k_cf)$(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6)$(BR2_ARM_CPU_ARMV7M),y)
  17. GMP_CONF_OPTS += --disable-assembly
  18. endif
  19. ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
  20. GMP_CONF_OPTS += --enable-cxx
  21. else
  22. GMP_CONF_OPTS += --disable-cxx
  23. endif
  24. $(eval $(autotools-package))
  25. $(eval $(host-autotools-package))