glm.mk 617 B

1234567891011121314151617181920212223
  1. ################################################################################
  2. #
  3. # glm
  4. #
  5. ################################################################################
  6. GLM_VERSION = 0.9.9.5
  7. GLM_SITE = $(call github,g-truc,glm,$(GLM_VERSION))
  8. GLM_LICENSE = MIT
  9. GLM_LICENSE_FILES = manual.md
  10. # GLM is a header-only library, it only makes sense
  11. # to have it installed into the staging directory.
  12. GLM_INSTALL_STAGING = YES
  13. GLM_INSTALL_TARGET = NO
  14. # Don't build libraries as GLM is header-only
  15. GLM_CONF_OPTS = \
  16. -DGLM_TEST_ENABLE=OFF \
  17. -DBUILD_SHARED_LIBS=OFF \
  18. -DBUILD_STATIC_LIBS=OFF
  19. $(eval $(cmake-package))