gcc.mk 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. ################################################################################
  2. #
  3. # Common variables for the gcc-initial and gcc-final packages.
  4. #
  5. ################################################################################
  6. #
  7. # Version, site and source
  8. #
  9. GCC_VERSION = $(call qstrip,$(BR2_GCC_VERSION))
  10. ifeq ($(BR2_GCC_VERSION_ARC),y)
  11. GCC_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,gcc,$(GCC_VERSION))
  12. GCC_SOURCE = gcc-$(GCC_VERSION).tar.gz
  13. else ifeq ($(BR2_GCC_VERSION_CSKY),y)
  14. GCC_SITE = $(call github,c-sky,gcc,$(GCC_VERSION))
  15. GCC_SOURCE = gcc-$(GCC_VERSION).tar.gz
  16. else
  17. GCC_SITE = $(BR2_GNU_MIRROR:/=)/gcc/gcc-$(GCC_VERSION)
  18. GCC_SOURCE = gcc-$(GCC_VERSION).tar.xz
  19. endif
  20. #
  21. # Xtensa special hook
  22. #
  23. define HOST_GCC_XTENSA_OVERLAY_EXTRACT
  24. $(call arch-xtensa-overlay-extract,$(@D),gcc)
  25. endef
  26. #
  27. # Apply patches
  28. #
  29. # gcc is a special package, not named gcc, but gcc-initial and
  30. # gcc-final, but patches are nonetheless stored in package/gcc in the
  31. # tree, and potentially in BR2_GLOBAL_PATCH_DIR directories as well.
  32. define HOST_GCC_APPLY_PATCHES
  33. for patchdir in \
  34. package/gcc/$(GCC_VERSION) \
  35. $(addsuffix /gcc/$(GCC_VERSION),$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  36. $(addsuffix /gcc,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) ; do \
  37. if test -d $${patchdir}; then \
  38. $(APPLY_PATCHES) $(@D) $${patchdir} \*.patch || exit 1; \
  39. fi; \
  40. done
  41. $(HOST_GCC_APPLY_POWERPC_PATCH)
  42. endef
  43. HOST_GCC_EXCLUDES = \
  44. libjava/* libgo/*
  45. #
  46. # Create 'build' directory and configure symlink
  47. #
  48. define HOST_GCC_CONFIGURE_SYMLINK
  49. mkdir -p $(@D)/build
  50. ln -sf ../configure $(@D)/build/configure
  51. endef
  52. #
  53. # Common configuration options
  54. #
  55. HOST_GCC_COMMON_DEPENDENCIES = \
  56. host-binutils \
  57. host-gmp \
  58. host-mpc \
  59. host-mpfr \
  60. $(if $(BR2_BINFMT_FLAT),host-elf2flt)
  61. HOST_GCC_COMMON_CONF_OPTS = \
  62. --target=$(GNU_TARGET_NAME) \
  63. --with-sysroot=$(STAGING_DIR) \
  64. --enable-__cxa_atexit \
  65. --with-gnu-ld \
  66. --disable-libssp \
  67. --disable-multilib \
  68. --disable-decimal-float \
  69. --with-gmp=$(HOST_DIR) \
  70. --with-mpc=$(HOST_DIR) \
  71. --with-mpfr=$(HOST_DIR) \
  72. --with-pkgversion="Buildroot $(BR2_VERSION_FULL)" \
  73. --with-bugurl="http://bugs.buildroot.net/" \
  74. --without-zstd
  75. # Don't build documentation. It takes up extra space / build time,
  76. # and sometimes needs specific makeinfo versions to work
  77. HOST_GCC_COMMON_CONF_ENV = \
  78. MAKEINFO=missing
  79. GCC_COMMON_TARGET_CFLAGS = $(TARGET_CFLAGS)
  80. GCC_COMMON_TARGET_CXXFLAGS = $(TARGET_CXXFLAGS)
  81. # used to fix ../../../../libsanitizer/libbacktrace/../../libbacktrace/elf.c:772:21: error: 'st.st_mode' may be used uninitialized in this function [-Werror=maybe-uninitialized]
  82. ifeq ($(BR2_ENABLE_DEBUG),y)
  83. GCC_COMMON_TARGET_CFLAGS += -Wno-error
  84. endif
  85. # Make sure libgcc & libstdc++ always get built with -matomic on ARC700
  86. ifeq ($(GCC_TARGET_CPU):$(BR2_ARC_ATOMIC_EXT),arc700:y)
  87. GCC_COMMON_TARGET_CFLAGS += -matomic
  88. GCC_COMMON_TARGET_CXXFLAGS += -matomic
  89. endif
  90. # Propagate options used for target software building to GCC target libs
  91. HOST_GCC_COMMON_CONF_ENV += CFLAGS_FOR_TARGET="$(GCC_COMMON_TARGET_CFLAGS)"
  92. HOST_GCC_COMMON_CONF_ENV += CXXFLAGS_FOR_TARGET="$(GCC_COMMON_TARGET_CXXFLAGS)"
  93. # libitm needs sparc V9+
  94. ifeq ($(BR2_sparc_v8)$(BR2_sparc_leon3),y)
  95. HOST_GCC_COMMON_CONF_OPTS += --disable-libitm
  96. endif
  97. # libmpx uses secure_getenv and struct _libc_fpstate not present in musl
  98. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_MUSL)$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),yy)
  99. HOST_GCC_COMMON_CONF_OPTS += --disable-libmpx
  100. endif
  101. # quadmath support requires wchar
  102. ifeq ($(BR2_USE_WCHAR)$(BR2_TOOLCHAIN_HAS_LIBQUADMATH),yy)
  103. HOST_GCC_COMMON_CONF_OPTS += --enable-libquadmath
  104. else
  105. HOST_GCC_COMMON_CONF_OPTS += --disable-libquadmath --disable-libquadmath-support
  106. endif
  107. # libsanitizer requires wordexp, not in default uClibc config. Also
  108. # doesn't build properly with musl.
  109. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_TOOLCHAIN_BUILDROOT_MUSL),y)
  110. HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
  111. endif
  112. # libsanitizer is broken for SPARC
  113. # https://bugs.busybox.net/show_bug.cgi?id=7951
  114. ifeq ($(BR2_sparc)$(BR2_sparc64),y)
  115. HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
  116. endif
  117. # The logic in libbacktrace/configure.ac to detect if __sync builtins
  118. # are available assumes they are as soon as target_subdir is not
  119. # empty, i.e when cross-compiling. However, some platforms do not have
  120. # __sync builtins, so help the configure script a bit.
  121. ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_4),)
  122. HOST_GCC_COMMON_CONF_ENV += target_configargs="libbacktrace_cv_sys_sync=no"
  123. endif
  124. # TLS support is not needed on uClibc/no-thread and
  125. # uClibc/linux-threads, otherwise, for all other situations (glibc,
  126. # musl and uClibc/NPTL), we need it.
  127. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_PTHREADS)$(BR2_PTHREADS_NONE),yy)
  128. HOST_GCC_COMMON_CONF_OPTS += --disable-tls
  129. else
  130. HOST_GCC_COMMON_CONF_OPTS += --enable-tls
  131. endif
  132. ifeq ($(BR2_GCC_ENABLE_LTO),y)
  133. HOST_GCC_COMMON_CONF_OPTS += --enable-plugins --enable-lto
  134. endif
  135. ifeq ($(BR2_PTHREADS_NONE),y)
  136. HOST_GCC_COMMON_CONF_OPTS += \
  137. --disable-threads \
  138. --disable-libitm \
  139. --disable-libatomic
  140. else
  141. HOST_GCC_COMMON_CONF_OPTS += --enable-threads
  142. endif
  143. # gcc 5 doesn't need cloog any more, see
  144. # https://gcc.gnu.org/gcc-5/changes.html and we don't support graphite
  145. # on GCC 4.9.x, so only isl is needed.
  146. ifeq ($(BR2_GCC_ENABLE_GRAPHITE),y)
  147. HOST_GCC_COMMON_DEPENDENCIES += host-isl
  148. HOST_GCC_COMMON_CONF_OPTS += --with-isl=$(HOST_DIR)
  149. else
  150. HOST_GCC_COMMON_CONF_OPTS += --without-isl --without-cloog
  151. endif
  152. ifeq ($(BR2_arc),y)
  153. HOST_GCC_COMMON_DEPENDENCIES += host-flex host-bison
  154. endif
  155. ifeq ($(BR2_SOFT_FLOAT),y)
  156. # only mips*-*-*, arm*-*-* and sparc*-*-* accept --with-float
  157. # powerpc seems to be needing it as well
  158. ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el)$(BR2_powerpc)$(BR2_sparc),y)
  159. HOST_GCC_COMMON_CONF_OPTS += --with-float=soft
  160. endif
  161. endif
  162. # Determine arch/tune/abi/cpu options
  163. ifneq ($(GCC_TARGET_ARCH),)
  164. HOST_GCC_COMMON_CONF_OPTS += --with-arch="$(GCC_TARGET_ARCH)"
  165. endif
  166. ifneq ($(GCC_TARGET_ABI),)
  167. HOST_GCC_COMMON_CONF_OPTS += --with-abi="$(GCC_TARGET_ABI)"
  168. endif
  169. ifeq ($(BR2_TOOLCHAIN_HAS_MNAN_OPTION),y)
  170. ifneq ($(GCC_TARGET_NAN),)
  171. HOST_GCC_COMMON_CONF_OPTS += --with-nan="$(GCC_TARGET_NAN)"
  172. endif
  173. endif
  174. ifneq ($(GCC_TARGET_FP32_MODE),)
  175. HOST_GCC_COMMON_CONF_OPTS += --with-fp-32="$(GCC_TARGET_FP32_MODE)"
  176. endif
  177. ifneq ($(GCC_TARGET_CPU),)
  178. HOST_GCC_COMMON_CONF_OPTS += --with-cpu=$(GCC_TARGET_CPU)
  179. endif
  180. ifneq ($(GCC_TARGET_FPU),)
  181. HOST_GCC_COMMON_CONF_OPTS += --with-fpu=$(GCC_TARGET_FPU)
  182. endif
  183. ifneq ($(GCC_TARGET_FLOAT_ABI),)
  184. HOST_GCC_COMMON_CONF_OPTS += --with-float=$(GCC_TARGET_FLOAT_ABI)
  185. endif
  186. ifneq ($(GCC_TARGET_MODE),)
  187. HOST_GCC_COMMON_CONF_OPTS += --with-mode=$(GCC_TARGET_MODE)
  188. endif
  189. # Enable proper double/long double for SPE ABI
  190. ifeq ($(BR2_powerpc_SPE),y)
  191. HOST_GCC_COMMON_CONF_OPTS += \
  192. --enable-obsolete \
  193. --enable-e500_double \
  194. --with-long-double-128
  195. endif
  196. # Set default to Secure-PLT to prevent run-time
  197. # generation of PLT stubs (supports RELRO and
  198. # SELinux non-exemem capabilities)
  199. ifeq ($(BR2_powerpc),y)
  200. HOST_GCC_COMMON_CONF_OPTS += --enable-secureplt
  201. endif
  202. # PowerPC64 big endian by default uses the elfv1 ABI, and PowerPC 64
  203. # little endian by default uses the elfv2 ABI. However, musl has
  204. # decided to use the elfv2 ABI for both, so we force the elfv2 ABI for
  205. # Power64 big endian when the selected C library is musl.
  206. ifeq ($(BR2_TOOLCHAIN_USES_MUSL)$(BR2_powerpc64),yy)
  207. HOST_GCC_COMMON_CONF_OPTS += \
  208. --with-abi=elfv2 \
  209. --without-long-double-128
  210. endif
  211. # Since glibc >= 2.26, poerpc64le requires double/long double which
  212. # requires at least gcc 6.2.
  213. # See sysdeps/powerpc/powerpc64le/configure.ac
  214. ifeq ($(BR2_TOOLCHAIN_USES_GLIBC)$(BR2_TOOLCHAIN_GCC_AT_LEAST_6)$(BR2_powerpc64le),yyy)
  215. HOST_GCC_COMMON_CONF_OPTS += \
  216. --with-long-double-128
  217. endif
  218. ifeq ($(BR2_s390x),y)
  219. HOST_GCC_COMMON_CONF_OPTS += \
  220. --with-long-double-128
  221. endif
  222. HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CROSS_PATH_SUFFIX='".br_real"'
  223. # For gcc-initial, we need to tell gcc that the C library will be
  224. # providing the ssp support, as it can't guess it since the C library
  225. # hasn't been built yet.
  226. #
  227. # For gcc-final, the gcc logic to detect whether SSP support is
  228. # available or not in the C library is not working properly for
  229. # uClibc, so let's be explicit as well.
  230. HOST_GCC_COMMON_MAKE_OPTS = \
  231. gcc_cv_libc_provides_ssp=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
  232. ifeq ($(BR2_CCACHE),y)
  233. HOST_GCC_COMMON_CCACHE_HASH_FILES += $(GCC_DL_DIR)/$(GCC_SOURCE)
  234. # Cfr. PATCH_BASE_DIRS in .stamp_patched, but we catch both versioned
  235. # and unversioned patches unconditionally. Moreover, to facilitate the
  236. # addition of gcc patches in BR2_GLOBAL_PATCH_DIR, we allow them to be
  237. # stored in a sub-directory called 'gcc' even if it's not technically
  238. # the name of the package.
  239. HOST_GCC_COMMON_CCACHE_HASH_FILES += \
  240. $(sort $(wildcard \
  241. package/gcc/$(GCC_VERSION)/*.patch \
  242. $(addsuffix /$($(PKG)_RAWNAME)/$(GCC_VERSION)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  243. $(addsuffix /$($(PKG)_RAWNAME)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  244. $(addsuffix /gcc/$(GCC_VERSION)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  245. $(addsuffix /gcc/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR)))))
  246. ifeq ($(BR2_xtensa),y)
  247. HOST_GCC_COMMON_CCACHE_HASH_FILES += $(ARCH_XTENSA_OVERLAY_TAR)
  248. endif
  249. # _CONF_OPTS contains some references to the absolute path of $(HOST_DIR)
  250. # and a reference to the Buildroot git revision (BR2_VERSION_FULL),
  251. # so substitute those away.
  252. HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CCACHE_HASH=\"`\
  253. printf '%s\n' $(subst $(HOST_DIR),@HOST_DIR@,\
  254. $(subst --with-pkgversion="Buildroot $(BR2_VERSION_FULL)",,$($(PKG)_CONF_OPTS))) \
  255. | sha256sum - $(HOST_GCC_COMMON_CCACHE_HASH_FILES) \
  256. | cut -c -64 | tr -d '\n'`\"
  257. endif # BR2_CCACHE
  258. # The LTO support in gcc creates wrappers for ar, ranlib and nm which load
  259. # the lto plugin. These wrappers are called *-gcc-ar, *-gcc-ranlib, and
  260. # *-gcc-nm and should be used instead of the real programs when -flto is
  261. # used. However, we should not add the toolchain wrapper for them, and they
  262. # match the *cc-* pattern. Therefore, an additional case is added for *-ar,
  263. # *-ranlib and *-nm.
  264. # According to gfortran manpage, it supports all options supported by gcc, so
  265. # add gfortran to the list of the program called via the Buildroot wrapper.
  266. # Avoid that a .br_real is symlinked a second time.
  267. # Also create <arch>-linux-<tool> symlinks.
  268. define HOST_GCC_INSTALL_WRAPPER_AND_SIMPLE_SYMLINKS
  269. $(Q)cd $(HOST_DIR)/bin; \
  270. for i in $(GNU_TARGET_NAME)-*; do \
  271. case "$$i" in \
  272. *.br_real) \
  273. ;; \
  274. *-ar|*-ranlib|*-nm) \
  275. ln -snf $$i $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  276. ;; \
  277. *cc|*cc-*|*++|*++-*|*cpp|*-gfortran|*-gdc) \
  278. rm -f $$i.br_real; \
  279. mv $$i $$i.br_real; \
  280. ln -sf toolchain-wrapper $$i; \
  281. ln -sf toolchain-wrapper $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  282. ln -snf $$i.br_real $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}.br_real; \
  283. ;; \
  284. *) \
  285. ln -snf $$i $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  286. ;; \
  287. esac; \
  288. done
  289. endef
  290. include $(sort $(wildcard package/gcc/*/*.mk))