gawk.mk 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. ################################################################################
  2. #
  3. # gawk
  4. #
  5. ################################################################################
  6. GAWK_VERSION = 5.1.0
  7. GAWK_SOURCE = gawk-$(GAWK_VERSION).tar.xz
  8. GAWK_SITE = $(BR2_GNU_MIRROR)/gawk
  9. GAWK_DEPENDENCIES = host-gawk
  10. GAWK_LICENSE = GPL-3.0+
  11. GAWK_LICENSE_FILES = COPYING
  12. ifeq ($(BR2_PACKAGE_LIBSIGSEGV),y)
  13. GAWK_DEPENDENCIES += libsigsegv
  14. endif
  15. # --with-mpfr requires an argument so just let
  16. # configure find it automatically
  17. ifeq ($(BR2_PACKAGE_MPFR),y)
  18. GAWK_DEPENDENCIES += mpfr
  19. else
  20. GAWK_CONF_OPTS += --without-mpfr
  21. endif
  22. # --with-readline requires an argument so just let
  23. # configure find it automatically
  24. ifeq ($(BR2_PACKAGE_READLINE),y)
  25. GAWK_DEPENDENCIES += readline
  26. else
  27. GAWK_CONF_OPTS += --without-readline
  28. endif
  29. HOST_GAWK_CONF_OPTS = --without-readline --without-mpfr
  30. define GAWK_CREATE_SYMLINK
  31. ln -sf gawk $(TARGET_DIR)/usr/bin/awk
  32. endef
  33. GAWK_POST_INSTALL_TARGET_HOOKS += GAWK_CREATE_SYMLINK
  34. $(eval $(autotools-package))
  35. $(eval $(host-autotools-package))