gauche.mk 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. ################################################################################
  2. #
  3. # gauche
  4. #
  5. ################################################################################
  6. GAUCHE_VERSION = 0.9.9
  7. GAUCHE_SOURCE = Gauche-$(GAUCHE_VERSION).tgz
  8. GAUCHE_SITE = http://downloads.sourceforge.net/project/gauche/Gauche
  9. GAUCHE_LICENSE = BSD-3-Clause, Boehm-gc, SRFI (srfi-11.scm), reload (reload.scm)
  10. GAUCHE_LICENSE_FILES = COPYING
  11. GAUCHE_DEPENDENCIES = host-gauche
  12. # We're patching configure.ac
  13. GAUCHE_AUTORECONF = YES
  14. HOST_GAUCHE_CONF_OPTS = --without-zlib
  15. GAUCHE_CONF_OPTS = --without-libatomic-ops
  16. # Enable embedded axTLS
  17. GAUCHE_TLS_LIBS = axtls
  18. ifeq ($(BR2_PACKAGE_MBEDTLS),y)
  19. GAUCHE_TLS_LIBS += mbedtls
  20. GAUCHE_DEPENDENCIES += mbedtls
  21. endif
  22. GAUCHE_CONF_OPTS += --with-tls="$(GAUCHE_TLS_LIBS)"
  23. ifeq ($(BR2_PACKAGE_ZLIB),y)
  24. GAUCHE_CONF_OPTS += --with-zlib=$(STAGING_DIR)
  25. GAUCHE_DEPENDENCIES += zlib
  26. else
  27. GAUCHE_CONF_OPTS += --without-zlib
  28. endif
  29. # Detection of c99 support in configure fails without WCHAR. To enable
  30. # automatic detection of c99 support by configure, we need to enable
  31. # WCHAR in toolchain. But actually we do not need WCHAR at gauche
  32. # runtime. So reuesting WCHAR in toolchain just for automatic detection
  33. # will be overkill. To solve this, explicitly -std=gnu99 is specified
  34. # here.
  35. GAUCHE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
  36. $(eval $(autotools-package))
  37. $(eval $(host-autotools-package))