freeswitch-mod-bcg729.mk 1.2 KB

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # freeswitch-mod-bcg729
  4. #
  5. ################################################################################
  6. FREESWITCH_MOD_BCG729_VERSION = 1.0.5
  7. FREESWITCH_MOD_BCG729_SITE = $(call github,xadhoom,mod_bcg729,v$(FREESWITCH_MOD_BCG729_VERSION))
  8. FREESWITCH_MOD_BCG729_LICENSE = MPL-1.1
  9. FREESWITCH_MOD_BCG729_LICENSE_FILES = LICENSE
  10. FREESWITCH_MOD_BCG729_DEPENDENCIES = freeswitch bcg729
  11. # instead of patching the not cross-compile friendly Makefile from
  12. # upstream we issue the necessary build commands ourselves
  13. define FREESWITCH_MOD_BCG729_BUILD_CMDS
  14. $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
  15. -I$(STAGING_DIR)/usr/include/freeswitch \
  16. -fPIC -fomit-frame-pointer -fno-exceptions \
  17. -c $(@D)/mod_bcg729.c -o $(@D)/mod_bcg729.o
  18. $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
  19. -fPIC -fomit-frame-pointer -fno-exceptions \
  20. -shared -Xlinker -x -lm -lbcg729 -Wl,-Bdynamic \
  21. -o $(@D)/mod_bcg729.so $(@D)/mod_bcg729.o
  22. endef
  23. define FREESWITCH_MOD_BCG729_INSTALL_TARGET_CMDS
  24. $(INSTALL) -m 0755 $(@D)/mod_bcg729.so $(TARGET_DIR)/usr/lib/freeswitch/mod/mod_bcg729.so
  25. endef
  26. $(eval $(generic-package))