fontconfig.mk 916 B

12345678910111213141516171819202122232425262728
  1. ################################################################################
  2. #
  3. # fontconfig
  4. #
  5. ################################################################################
  6. FONTCONFIG_VERSION = 2.13.1
  7. FONTCONFIG_SITE = http://fontconfig.org/release
  8. FONTCONFIG_SOURCE = fontconfig-$(FONTCONFIG_VERSION).tar.bz2
  9. # 0002-add-pthread-as-a-dependency-of-a-static-lib.patch
  10. FONTCONFIG_AUTORECONF = YES
  11. FONTCONFIG_INSTALL_STAGING = YES
  12. FONTCONFIG_DEPENDENCIES = freetype expat host-pkgconf host-gperf util-linux
  13. HOST_FONTCONFIG_DEPENDENCIES = \
  14. host-freetype host-expat host-pkgconf host-gperf host-util-linux
  15. FONTCONFIG_LICENSE = fontconfig license
  16. FONTCONFIG_LICENSE_FILES = COPYING
  17. FONTCONFIG_CONF_OPTS = \
  18. --with-arch=$(GNU_TARGET_NAME) \
  19. --with-cache-dir=/var/cache/fontconfig \
  20. --disable-docs
  21. HOST_FONTCONFIG_CONF_OPTS = \
  22. --disable-static
  23. $(eval $(autotools-package))
  24. $(eval $(host-autotools-package))