fluid-soundfont.mk 923 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # fluid-soundfont
  4. #
  5. ################################################################################
  6. FLUID_SOUNDFONT_VERSION = 3.1
  7. FLUID_SOUNDFONT_SOURCE = fluid-soundfont_$(FLUID_SOUNDFONT_VERSION).orig.tar.gz
  8. # The http://www.hammersound.net archive site seems unreliable (show HTTP 500
  9. # error), and also publish the file in the sfArk format, which is inconvenient
  10. # to be used in automated build. We use here the Debian mirror publishing the
  11. # file in a more convenient format (inative sf2 in a tar.gz archive).
  12. FLUID_SOUNDFONT_SITE = http://http.debian.net/debian/pool/main/f/fluid-soundfont
  13. FLUID_SOUNDFONT_LICENSE = MIT
  14. FLUID_SOUNDFONT_LICENSE_FILES = COPYING
  15. define FLUID_SOUNDFONT_INSTALL_TARGET_CMDS
  16. $(INSTALL) -D -m 0644 $(@D)/FluidR3_GM.sf2 $(TARGET_DIR)/usr/share/soundfonts/FluidR3_GM.sf2
  17. endef
  18. $(eval $(generic-package))