flare-engine.mk 1.1 KB

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # flare-engine
  4. #
  5. ################################################################################
  6. FLARE_ENGINE_VERSION = 1.0
  7. FLARE_ENGINE_SITE = $(call github,clintbellanger,flare-engine,v$(FLARE_ENGINE_VERSION))
  8. FLARE_ENGINE_LICENSE = GPL-3.0+
  9. FLARE_ENGINE_LICENSE_FILES = COPYING
  10. FLARE_ENGINE_DEPENDENCIES += sdl2 sdl2_image sdl2_mixer sdl2_ttf
  11. # Don't use /usr/games and /usr/share/games
  12. FLARE_ENGINE_CONF_OPTS += -DBINDIR=bin -DDATADIR=share/flare
  13. # Don't use the default Debug type as it adds -pg (gprof)
  14. ifeq ($(BR2_ENABLE_DEBUG),y)
  15. FLARE_ENGINE_CONF_OPTS += -DCMAKE_BUILD_TYPE=RelWithDebInfo
  16. endif
  17. ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
  18. # CMakeLists.txt sets CMAKE_CXX_FLAGS_<BUILD_TYPE> depending on
  19. # BUILD_TYPE, and this comes after the generic CMAKE_CXX_FLAGS.
  20. # Override CMAKE_BUILD_TYPE so no overrides are applied.
  21. FLARE_ENGINE_CONF_OPTS += -DCMAKE_BUILD_TYPE=Buildroot
  22. FLARE_ENGINE_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -O0"
  23. endif
  24. $(eval $(cmake-package))