fcgiwrap.mk 1015 B

123456789101112131415161718192021222324252627282930313233
  1. ################################################################################
  2. #
  3. # fcgiwrap
  4. #
  5. ################################################################################
  6. FCGIWRAP_VERSION = 99c942c90063c73734e56bacaa65f947772d9186
  7. FCGIWRAP_SITE = $(call github,gnosek,fcgiwrap,$(FCGIWRAP_VERSION))
  8. FCGIWRAP_DEPENDENCIES = host-pkgconf libfcgi
  9. FCGIWRAP_LICENSE = MIT
  10. FCGIWRAP_LICENSE_FILES = COPYING
  11. FCGIWRAP_AUTORECONF = YES
  12. FCGIWRAP_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -Wno-error"
  13. ifeq ($(BR2_PACKAGE_SYSTEMD),y)
  14. FCGIWRAP_DEPENDENCIES += systemd
  15. FCGIWRAP_CONF_OPTS += --with-systemd
  16. else
  17. FCGIWRAP_CONF_OPTS += --without-systemd
  18. endif
  19. # libfcgi needs libm and fcgiwrap does not use libtool or pkgconf to
  20. # detect libfcgi, so we need to add -lm explicitely when using static
  21. # libs.
  22. ifeq ($(BR2_STATIC_LIBS),y)
  23. FCGIWRAP_CONF_OPTS += LIBS=-lm
  24. endif
  25. # fcgiwrap uses Autoconf, but not Automake, so we need to provide
  26. # these to make.
  27. FCGIWRAP_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
  28. $(eval $(autotools-package))