fbv.mk 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. ################################################################################
  2. #
  3. # fbv
  4. #
  5. ################################################################################
  6. FBV_VERSION = 1.0b
  7. FBV_SITE = http://s-tech.elsat.net.pl/fbv
  8. FBV_LICENSE = GPL-2.0
  9. FBV_LICENSE_FILES = COPYING
  10. ### image format dependencies and configure options
  11. FBV_DEPENDENCIES = # empty
  12. FBV_CONFIGURE_OPTS = # empty
  13. ifeq ($(BR2_PACKAGE_FBV_PNG),y)
  14. FBV_DEPENDENCIES += libpng
  15. # libpng in turn depends on other libraries
  16. ifeq ($(BR2_STATIC_LIBS),y)
  17. FBV_CONFIGURE_OPTS += "--libs=`$(PKG_CONFIG_HOST_BINARY) --libs libpng`"
  18. endif
  19. else
  20. FBV_CONFIGURE_OPTS += --without-libpng
  21. endif
  22. ifeq ($(BR2_PACKAGE_FBV_JPEG),y)
  23. FBV_DEPENDENCIES += jpeg
  24. else
  25. FBV_CONFIGURE_OPTS += --without-libjpeg
  26. endif
  27. ifeq ($(BR2_PACKAGE_FBV_GIF),y)
  28. FBV_DEPENDENCIES += giflib
  29. else
  30. FBV_CONFIGURE_OPTS += --without-libungif
  31. endif
  32. #fbv doesn't support cross-compilation
  33. define FBV_CONFIGURE_CMDS
  34. (cd $(FBV_DIR); rm -f config.cache; \
  35. $(TARGET_CONFIGURE_OPTS) \
  36. $(TARGET_CONFIGURE_ARGS) \
  37. ./configure \
  38. --prefix=/usr \
  39. $(FBV_CONFIGURE_OPTS) \
  40. )
  41. endef
  42. define FBV_BUILD_CMDS
  43. $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
  44. endef
  45. define FBV_INSTALL_TARGET_CMDS
  46. $(INSTALL) -D $(@D)/fbv $(TARGET_DIR)/usr/bin/fbv
  47. endef
  48. $(eval $(autotools-package))