fbdump.mk 644 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # fbdump
  4. #
  5. ################################################################################
  6. FBDUMP_VERSION = 0.4.2
  7. FBDUMP_SITE = http://www.rcdrummond.net/fbdump
  8. FBDUMP_LICENSE = GPL-2.0
  9. FBDUMP_LICENSE_FILES = COPYING
  10. # The VGA16 specific feature of fbdump doesn't make much sense outside
  11. # of the x86/x86-64 architectures, and causes build problems on some
  12. # architectures as outw() is not always available.
  13. ifeq ($(BR2_i386)$(BR2_x86_64),y)
  14. FBDUMP_CONF_OPTS += --enable-vga16fb
  15. else
  16. FBDUMP_CONF_OPTS += --disable-vga16fb
  17. endif
  18. $(eval $(autotools-package))