fastd.mk 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ################################################################################
  2. #
  3. # fastd
  4. #
  5. ################################################################################
  6. FASTD_VERSION = 21
  7. FASTD_SITE = https://github.com/NeoRaider/fastd/releases/download/v$(FASTD_VERSION)
  8. FASTD_SOURCE = fastd-$(FASTD_VERSION).tar.xz
  9. FASTD_LICENSE = BSD-2-Clause
  10. FASTD_LICENSE_FILES = COPYRIGHT
  11. FASTD_DEPENDENCIES = host-bison host-pkgconf libuecc libsodium
  12. ifeq ($(BR2_PACKAGE_LIBCAP),y)
  13. FASTD_CONF_OPTS += -Dcapabilities=enabled
  14. FASTD_DEPENDENCIES += libcap
  15. else
  16. FASTD_CONF_OPTS += -Dcapabilities=disabled
  17. endif
  18. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  19. FASTD_CONF_OPTS += -Dcipher_aes128-ctr=enabled
  20. FASTD_DEPENDENCIES += openssl
  21. else
  22. FASTD_CONF_OPTS += -Dcipher_aes128-ctr=disabled
  23. endif
  24. ifeq ($(BR2_PACKAGE_FASTD_STATUS_SOCKET),y)
  25. FASTD_CONF_OPTS += -Dstatus_socket=enabled
  26. FASTD_DEPENDENCIES += json-c
  27. else
  28. FASTD_CONF_OPTS += -Dstatus_socket=disabled
  29. endif
  30. ifeq ($(BR2_INIT_SYSTEMD),y)
  31. FASTD_CONF_OPTS += -Dsystemd=enabled
  32. else
  33. FASTD_CONF_OPTS += -Dsystemd=disabled
  34. endif
  35. ifeq ($(BR2_GCC_ENABLE_LTO),y)
  36. FASTD_CONF_OPTS += -Db_lto=true
  37. else
  38. FASTD_CONF_OPTS += -Db_lto=false
  39. endif
  40. $(eval $(meson-package))