f2fs-tools.mk 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. ################################################################################
  2. #
  3. # f2fs-tools
  4. #
  5. ################################################################################
  6. F2FS_TOOLS_VERSION = 1.14.0
  7. F2FS_TOOLS_SITE = https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot
  8. F2FS_TOOLS_CONF_ENV = ac_cv_file__git=no
  9. F2FS_TOOLS_DEPENDENCIES = host-pkgconf util-linux
  10. HOST_F2FS_TOOLS_DEPENDENCIES = host-pkgconf host-util-linux
  11. # GIT version, shipped without configure
  12. F2FS_TOOLS_AUTORECONF = YES
  13. F2FS_TOOLS_INSTALL_STAGING = YES
  14. F2FS_TOOLS_LICENSE = GPL-2.0
  15. F2FS_TOOLS_LICENSE_FILES = COPYING
  16. ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
  17. F2FS_TOOLS_CONF_OPTS += --with-selinux
  18. F2FS_TOOLS_DEPENDENCIES += libselinux
  19. else
  20. F2FS_TOOLS_CONF_OPTS += --without-selinux
  21. endif
  22. ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBBLKID),y)
  23. # util-linux is a dependency already, no need to list it again
  24. F2FS_TOOLS_CONF_OPTS += --with-blkid
  25. else
  26. F2FS_TOOLS_CONF_OPTS += --without-blkid
  27. endif
  28. # blkid is only used to detect if we're overwriting a filesystem
  29. # during mkfs, which only makes sense on the target, so we disable
  30. # blkid support even if we have host-util-linux
  31. HOST_F2FS_TOOLS_CONF_OPTS = \
  32. --without-selinux \
  33. --without-blkid
  34. $(eval $(autotools-package))
  35. $(eval $(host-autotools-package))