evemu.mk 1.1 KB

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # evemu
  4. #
  5. ################################################################################
  6. EVEMU_VERSION = 2.7.0
  7. EVEMU_SITE = http://www.freedesktop.org/software/evemu
  8. EVEMU_SOURCE = evemu-$(EVEMU_VERSION).tar.xz
  9. EVEMU_LICENSE = LGPL-3.0 (library), GPL-3.0 (tools)
  10. EVEMU_LICENSE_FILES = COPYING
  11. # asciidoc used to generate manpages, which we don't need, and if it's
  12. # present on the build host, it ends getting called with our host-python
  13. # which doesn't have all the needed modules enabled, breaking the build
  14. EVEMU_CONF_ENV = ac_cv_path_ASCIIDOC=""
  15. # disable tests generation because of C++ dependency
  16. EVEMU_CONF_OPTS += --disable-tests
  17. # Uses PKG_CHECK_MODULES() in configure.ac
  18. EVEMU_DEPENDENCIES = host-pkgconf libevdev
  19. # Check for target python
  20. ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
  21. EVEMU_CONF_OPTS += --enable-python-bindings
  22. EVEMU_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON3),python3,python)
  23. else
  24. EVEMU_CONF_OPTS += --disable-python-bindings
  25. endif
  26. $(eval $(autotools-package))