ebtables.mk 1.1 KB

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # ebtables
  4. #
  5. ################################################################################
  6. EBTABLES_VERSION = 2.0.11
  7. EBTABLES_SITE = http://ftp.netfilter.org/pub/ebtables
  8. EBTABLES_LICENSE = GPL-2.0+
  9. EBTABLES_LICENSE_FILES = COPYING
  10. ifeq ($(BR2_PACKAGE_EBTABLES_UTILS_SAVE),y)
  11. define EBTABLES_INSTALL_TARGET_UTILS_SAVE
  12. $(INSTALL) -m 0755 -D $(@D)/ebtables-save.sh $(TARGET_DIR)/usr/sbin/ebtables-legacy-save
  13. endef
  14. EBTABLES_POST_INSTALL_TARGET_HOOKS += EBTABLES_INSTALL_TARGET_UTILS_SAVE
  15. else
  16. # ebtables-legacy-save is installed by default, thus remove it from target
  17. define EBTABLES_REMOVE_UTILS_SAVE
  18. $(RM) -f $(TARGET_DIR)/usr/sbin/ebtables-legacy-save
  19. endef
  20. EBTABLES_POST_INSTALL_TARGET_HOOKS += EBTABLES_REMOVE_UTILS_SAVE
  21. endif
  22. # ebtables-legacy-restore is installed by default, thus remove it if not
  23. # selected
  24. ifeq ($(BR2_PACKAGE_EBTABLES_UTILS_RESTORE),)
  25. define EBTABLES_REMOVE_UTILS_RESTORE
  26. $(RM) -f $(TARGET_DIR)/usr/sbin/ebtables-legacy-restore
  27. endef
  28. EBTABLES_POST_INSTALL_TARGET_HOOKS += EBTABLES_REMOVE_UTILS_RESTORE
  29. endif
  30. $(eval $(autotools-package))