e2tools.mk 620 B

1234567891011121314151617181920
  1. ################################################################################
  2. #
  3. # e2tools
  4. #
  5. ################################################################################
  6. E2TOOLS_VERSION = 0.0.16.4
  7. E2TOOLS_SITE = $(call github,ndim,e2tools,v$(E2TOOLS_VERSION))
  8. # Source coming from GitHub, no configure included.
  9. E2TOOLS_AUTORECONF = YES
  10. E2TOOLS_LICENSE = GPL-2.0
  11. E2TOOLS_LICENSE_FILES = COPYING
  12. E2TOOLS_DEPENDENCIES = e2fsprogs
  13. E2TOOLS_CONF_ENV = LIBS="-lpthread"
  14. HOST_E2TOOLS_DEPENDENCIES = host-e2fsprogs
  15. HOST_E2TOOLS_CONF_ENV = LIBS="-lpthread"
  16. $(eval $(autotools-package))
  17. $(eval $(host-autotools-package))