directfb.mk 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. ################################################################################
  2. #
  3. # directfb
  4. #
  5. ################################################################################
  6. DIRECTFB_VERSION_MAJOR = 1.7
  7. DIRECTFB_VERSION = $(DIRECTFB_VERSION_MAJOR).7
  8. DIRECTFB_SITE = http://www.directfb.org/downloads/Core/DirectFB-$(DIRECTFB_VERSION_MAJOR)
  9. DIRECTFB_SOURCE = DirectFB-$(DIRECTFB_VERSION).tar.gz
  10. DIRECTFB_LICENSE = LGPL-2.1+
  11. DIRECTFB_LICENSE_FILES = COPYING
  12. DIRECTFB_INSTALL_STAGING = YES
  13. DIRECTFB_AUTORECONF = YES
  14. DIRECTFB_CONF_OPTS = \
  15. --enable-zlib \
  16. --enable-freetype \
  17. --enable-fbdev \
  18. --disable-sdl \
  19. --disable-vnc \
  20. --disable-osx \
  21. --disable-video4linux \
  22. --disable-video4linux2 \
  23. --without-tools \
  24. --disable-x11
  25. ifeq ($(BR2_STATIC_LIBS),y)
  26. DIRECTFB_CONF_OPTS += --disable-dynload
  27. endif
  28. DIRECTFB_CONFIG_SCRIPTS = directfb-config
  29. DIRECTFB_DEPENDENCIES = freetype zlib
  30. ifeq ($(BR2_PACKAGE_DIRECTFB_MULTI),y)
  31. DIRECTFB_CONF_OPTS += --enable-multi --enable-multi-kernel
  32. DIRECTFB_DEPENDENCIES += linux-fusion
  33. else
  34. DIRECTFB_CONF_OPTS += --disable-multi --disable-multi-kernel
  35. endif
  36. ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
  37. DIRECTFB_CONF_OPTS += --enable-debug-support
  38. ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
  39. DIRECTFB_CONF_OPTS += --enable-debug
  40. endif
  41. else
  42. DIRECTFB_CONF_OPTS += --disable-debug-support
  43. endif
  44. ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
  45. DIRECTFB_CONF_OPTS += --enable-trace
  46. endif
  47. ifeq ($(BR2_PACKAGE_DIRECTFB_DIVINE),y)
  48. DIRECTFB_CONF_OPTS += --enable-divine
  49. else
  50. DIRECTFB_CONF_OPTS += --disable-divine
  51. endif
  52. ifeq ($(BR2_PACKAGE_DIRECTFB_SAWMAN),y)
  53. DIRECTFB_CONF_OPTS += --enable-sawman
  54. else
  55. DIRECTFB_CONF_OPTS += --disable-sawman
  56. endif
  57. DIRECTFB_GFX = \
  58. $(if $(BR2_PACKAGE_DIRECTFB_ATI128),ati128) \
  59. $(if $(BR2_PACKAGE_DIRECTFB_CYBER5K),cyber5k) \
  60. $(if $(BR2_PACKAGE_DIRECTFB_MATROX),matrox) \
  61. $(if $(BR2_PACKAGE_DIRECTFB_PXA3XX),pxa3xx) \
  62. $(if $(BR2_PACKAGE_DIRECTFB_I830),i830) \
  63. $(if $(BR2_PACKAGE_DIRECTFB_EP9X),ep9x)
  64. ifeq ($(strip $(DIRECTFB_GFX)),)
  65. DIRECTFB_CONF_OPTS += --with-gfxdrivers=none
  66. else
  67. DIRECTFB_CONF_OPTS += \
  68. --with-gfxdrivers=$(subst $(space),$(comma),$(strip $(DIRECTFB_GFX)))
  69. endif
  70. DIRECTFB_INPUT = \
  71. $(if $(BR2_PACKAGE_DIRECTFB_LINUXINPUT),linuxinput) \
  72. $(if $(BR2_PACKAGE_DIRECTFB_KEYBOARD),keyboard) \
  73. $(if $(BR2_PACKAGE_DIRECTFB_PS2MOUSE),ps2mouse) \
  74. $(if $(BR2_PACKAGE_DIRECTFB_SERIALMOUSE),serialmouse) \
  75. $(if $(BR2_PACKAGE_DIRECTFB_TSLIB),tslib)
  76. ifeq ($(BR2_PACKAGE_DIRECTFB_TSLIB),y)
  77. DIRECTFB_DEPENDENCIES += tslib
  78. endif
  79. ifeq ($(strip $(DIRECTFB_INPUT)),)
  80. DIRECTFB_CONF_OPTS += --with-inputdrivers=none
  81. else
  82. DIRECTFB_CONF_OPTS += \
  83. --with-inputdrivers=$(subst $(space),$(comma),$(strip $(DIRECTFB_INPUT)))
  84. endif
  85. ifeq ($(BR2_PACKAGE_DIRECTFB_GIF),y)
  86. DIRECTFB_CONF_OPTS += --enable-gif
  87. else
  88. DIRECTFB_CONF_OPTS += --disable-gif
  89. endif
  90. ifeq ($(BR2_PACKAGE_DIRECTFB_TIFF),y)
  91. DIRECTFB_CONF_OPTS += --enable-tiff
  92. DIRECTFB_DEPENDENCIES += tiff
  93. else
  94. DIRECTFB_CONF_OPTS += --disable-tiff
  95. endif
  96. ifeq ($(BR2_PACKAGE_DIRECTFB_PNG),y)
  97. DIRECTFB_CONF_OPTS += --enable-png
  98. DIRECTFB_DEPENDENCIES += libpng
  99. DIRECTFB_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
  100. else
  101. DIRECTFB_CONF_OPTS += --disable-png
  102. endif
  103. ifeq ($(BR2_PACKAGE_DIRECTFB_JPEG),y)
  104. DIRECTFB_CONF_OPTS += --enable-jpeg
  105. DIRECTFB_DEPENDENCIES += jpeg
  106. else
  107. DIRECTFB_CONF_OPTS += --disable-jpeg
  108. endif
  109. ifeq ($(BR2_PACKAGE_DIRECTFB_SVG),y)
  110. DIRECTFB_CONF_OPTS += --enable-svg
  111. # needs some help to find cairo includes
  112. DIRECTFB_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/cairo"
  113. DIRECTFB_DEPENDENCIES += libsvg-cairo
  114. else
  115. DIRECTFB_CONF_OPTS += --disable-svg
  116. endif
  117. ifeq ($(BR2_PACKAGE_DIRECTFB_IMLIB2),y)
  118. DIRECTFB_CONF_OPTS += --enable-imlib2
  119. DIRECTFB_DEPENDENCIES += imlib2
  120. DIRECTFB_CONF_ENV += ac_cv_path_IMLIB2_CONFIG=$(STAGING_DIR)/usr/bin/imlib2-config
  121. else
  122. DIRECTFB_CONF_OPTS += --disable-imlib2
  123. endif
  124. ifeq ($(BR2_PACKAGE_DIRECTFB_DITHER_RGB16),y)
  125. DIRECTFB_CONF_OPTS += --with-dither-rgb16=advanced
  126. else
  127. DIRECTFB_CONF_OPTS += --with-dither-rgb16=none
  128. endif
  129. ifeq ($(BR2_PACKAGE_DIRECTFB_TESTS),y)
  130. DIRECTFB_CONF_OPTS += --with-tests
  131. endif
  132. HOST_DIRECTFB_DEPENDENCIES = host-pkgconf host-libpng
  133. HOST_DIRECTFB_CONF_OPTS = \
  134. --disable-multi \
  135. --enable-png \
  136. --with-gfxdrivers=none \
  137. --with-inputdrivers=none
  138. HOST_DIRECTFB_BUILD_CMDS = \
  139. $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/tools directfb-csource
  140. HOST_DIRECTFB_INSTALL_CMDS = \
  141. $(INSTALL) -m 0755 $(@D)/tools/directfb-csource $(HOST_DIR)/bin
  142. $(eval $(autotools-package))
  143. $(eval $(host-autotools-package))
  144. # directfb-csource for the host
  145. DIRECTFB_HOST_BINARY = $(HOST_DIR)/bin/directfb-csource