dillo.mk 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. ################################################################################
  2. #
  3. # dillo
  4. #
  5. ################################################################################
  6. DILLO_VERSION = 3.0.5
  7. DILLO_SOURCE = dillo-$(DILLO_VERSION).tar.bz2
  8. DILLO_SITE = http://www.dillo.org/download
  9. DILLO_LICENSE = GPL-3.0+
  10. DILLO_LICENSE_FILES = COPYING
  11. # configure.ac gets patched, so autoreconf is necessary
  12. DILLO_AUTORECONF = YES
  13. DILLO_DEPENDENCIES = fltk zlib \
  14. $(if $(BR2_PACKAGE_LIBICONV),libiconv)
  15. DILLO_CONF_ENV = ac_cv_path_FLTK_CONFIG=$(STAGING_DIR)/usr/bin/fltk-config
  16. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  17. DILLO_CONF_OPTS += --enable-ssl
  18. DILLO_DEPENDENCIES += openssl
  19. else
  20. DILLO_CONF_OPTS += --disable-ssl
  21. endif
  22. ifeq ($(BR2_PACKAGE_LIBPNG),y)
  23. DILLO_CONF_OPTS += --enable-png
  24. DILLO_DEPENDENCIES += libpng
  25. DILLO_CONF_ENV += PNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
  26. else
  27. DILLO_CONF_OPTS += --disable-png
  28. endif
  29. ifeq ($(BR2_PACKAGE_JPEG),y)
  30. DILLO_CONF_OPTS += --enable-jpeg
  31. DILLO_DEPENDENCIES += jpeg
  32. else
  33. DILLO_CONF_OPTS += --disable-jpeg
  34. endif
  35. ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
  36. DILLO_CONF_OPTS += --enable-threaded-dns
  37. else
  38. DILLO_CONF_OPTS += --disable-threaded-dns
  39. endif
  40. $(eval $(autotools-package))