diffutils.mk 674 B

1234567891011121314151617181920
  1. ################################################################################
  2. #
  3. # diffutils
  4. #
  5. ################################################################################
  6. DIFFUTILS_VERSION = 3.7
  7. DIFFUTILS_SOURCE = diffutils-$(DIFFUTILS_VERSION).tar.xz
  8. DIFFUTILS_SITE = $(BR2_GNU_MIRROR)/diffutils
  9. DIFFUTILS_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
  10. DIFFUTILS_LICENSE = GPL-3.0+
  11. DIFFUTILS_LICENSE_FILES = COPYING
  12. # Since glibc >= 2.26, don't try to use getopt_long replacement bundled
  13. # with diffutils. It will conflict with the one from glibc.
  14. ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),y)
  15. DIFFUTILS_CONF_ENV += gl_cv_func_getopt_gnu=yes
  16. endif
  17. $(eval $(autotools-package))