dbus-glib.mk 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. ################################################################################
  2. #
  3. # dbus-glib
  4. #
  5. ################################################################################
  6. DBUS_GLIB_VERSION = 0.110
  7. DBUS_GLIB_SITE = http://dbus.freedesktop.org/releases/dbus-glib
  8. DBUS_GLIB_INSTALL_STAGING = YES
  9. DBUS_GLIB_LICENSE = AFL-2.1 or GPL-2.0+
  10. DBUS_GLIB_LICENSE_FILES = COPYING
  11. DBUS_GLIB_CONF_ENV = \
  12. ac_cv_have_abstract_sockets=yes \
  13. ac_cv_func_posix_getpwnam_r=yes \
  14. have_abstract_sockets=yes
  15. DBUS_GLIB_CONF_OPTS = \
  16. --disable-tests \
  17. --disable-xml-docs \
  18. --with-introspect-xml=$(DBUS_HOST_INTROSPECT) \
  19. --with-dbus-binding-tool=$(DBUS_GLIB_HOST_BINARY) \
  20. --disable-bash-completion \
  21. --disable-doxygen-docs \
  22. --enable-asserts=yes
  23. DBUS_GLIB_DEPENDENCIES = host-pkgconf dbus host-dbus host-dbus-glib libglib2 expat
  24. HOST_DBUS_GLIB_DEPENDENCIES = host-dbus host-expat host-libglib2
  25. HOST_DBUS_GLIB_CONF_OPTS = \
  26. --disable-tests \
  27. --disable-xml-docs \
  28. --disable-bash-completion \
  29. --disable-doxygen-docs \
  30. --enable-asserts=yes
  31. $(eval $(autotools-package))
  32. $(eval $(host-autotools-package))
  33. # dbus-glib for the host
  34. DBUS_GLIB_HOST_BINARY = $(HOST_DIR)/bin/dbus-binding-tool