dbus-cpp.mk 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. ################################################################################
  2. #
  3. # dbus-cpp
  4. #
  5. ################################################################################
  6. DBUS_CPP_VERSION = 0.9.0
  7. DBUS_CPP_SITE = http://downloads.sourceforge.net/project/dbus-cplusplus/dbus-c++/$(DBUS_CPP_VERSION)
  8. DBUS_CPP_SOURCE = libdbus-c++-$(DBUS_CPP_VERSION).tar.gz
  9. DBUS_CPP_INSTALL_STAGING = YES
  10. # expat is required for the tools irrespective of dbus xml backend
  11. DBUS_CPP_DEPENDENCIES = host-dbus-cpp host-pkgconf dbus expat
  12. HOST_DBUS_CPP_DEPENDENCIES = host-pkgconf host-dbus host-expat
  13. DBUS_CPP_CONF_OPTS = \
  14. --disable-examples \
  15. --disable-tests \
  16. --disable-doxygen-docs \
  17. --with-build-libdbus-cxx=$(HOST_DBUS_CPP_BUILDDIR)
  18. HOST_DBUS_CPP_CONF_OPTS = \
  19. --disable-examples \
  20. --disable-tests \
  21. --disable-doxygen-docs \
  22. --disable-ecore \
  23. --disable-glib
  24. DBUS_CPP_AUTORECONF = YES
  25. DBUS_CPP_LICENSE = LGPL-2.1+
  26. DBUS_CPP_LICENSE_FILES = COPYING
  27. ifeq ($(BR2_PACKAGE_EFL),y)
  28. DBUS_CPP_CONF_OPTS += --enable-ecore
  29. DBUS_CPP_DEPENDENCIES += efl
  30. else
  31. DBUS_CPP_CONF_OPTS += --disable-ecore
  32. endif
  33. ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
  34. DBUS_CPP_CONF_OPTS += --enable-glib
  35. DBUS_CPP_DEPENDENCIES += libglib2
  36. else
  37. DBUS_CPP_CONF_OPTS += --disable-glib
  38. endif
  39. $(eval $(autotools-package))
  40. $(eval $(host-autotools-package))