dahdi-tools.mk 916 B

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # dahdi-tools
  4. #
  5. ################################################################################
  6. DAHDI_TOOLS_VERSION = 3.0.0
  7. DAHDI_TOOLS_SITE = http://downloads.asterisk.org/pub/telephony/dahdi-tools/releases
  8. DAHDI_TOOLS_LICENSE = GPLv2, LGPLv2.1
  9. DAHDI_TOOLS_LICENSE_FILES = LICENSE LICENSE.LGPL
  10. DAHDI_TOOLS_DEPENDENCIES = dahdi-linux perl
  11. DAHDI_TOOLS_INSTALL_STAGING = YES
  12. DAHDI_TOOLS_AUTORECONF = YES
  13. # Buildroot globally exports PERL with the value it has on the host, so we need
  14. # to override it with the location where it will be on the target.
  15. DAHDI_TOOLS_CONF_ENV = PERL=/usr/bin/perl
  16. DAHDI_TOOLS_CONF_OPTS = \
  17. --without-newt \
  18. --without-usb \
  19. --without-pcap \
  20. --without-libusbx \
  21. --without-libusb \
  22. --without-selinux \
  23. --without-ppp \
  24. --with-perllib=/usr/lib/perl5/$(PERL_VERSION)
  25. $(eval $(autotools-package))