cxxtest.mk 1.2 KB

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # cxxtest
  4. #
  5. ################################################################################
  6. CXXTEST_VERSION = 4.4
  7. CXXTEST_SITE = https://github.com/CxxTest/cxxtest/releases/download/$(CXXTEST_VERSION)
  8. CXXTEST_LICENSE = LGPL-3.0
  9. CXXTEST_LICENSE_FILES = COPYING
  10. CXXTEST_INSTALL_STAGING = YES
  11. CXXTEST_INSTALL_TARGET = NO
  12. CXXTEST_DEPENDENCIES = host-cxxtest
  13. HOST_CXXTEST_SETUP_TYPE = setuptools
  14. HOST_CXXTEST_SUBDIR = python
  15. # Copy CxxTest header files to staging directory
  16. define CXXTEST_INSTALL_STAGING_CMDS
  17. $(INSTALL) -m 755 -d $(STAGING_DIR)/usr/include/cxxtest
  18. $(INSTALL) -m 644 -t $(STAGING_DIR)/usr/include/cxxtest $(@D)/cxxtest/*
  19. endef
  20. # CxxTest uses python infrastructure as the build system. It consists of two parts:
  21. # 1. cxxtestgen tool to process tests defined in header files to generate C++ source
  22. # files. cxxtestgen is built as a host package, so that it can be used natively.
  23. # 2. A set of header files which are installed in staging directory. This will be
  24. # used in cross-compiling test harness to generate executable which will run on target.
  25. $(eval $(generic-package))
  26. $(eval $(host-python-package))