cwiid.mk 838 B

1234567891011121314151617181920212223242526272829
  1. ################################################################################
  2. #
  3. # cwiid
  4. #
  5. ################################################################################
  6. CWIID_VERSION = fadf11e89b579bcc0336a0692ac15c93785f3f82
  7. CWIID_SITE = $(call github,abstrakraft,cwiid,$(CWIID_VERSION))
  8. CWIID_LICENSE = GPL-2.0+
  9. CWIID_LICENSE_FILES = COPYING
  10. CWIID_AUTORECONF = YES
  11. CWIID_INSTALL_STAGING = YES
  12. CWIID_DEPENDENCIES = host-pkgconf host-bison host-flex bluez5_utils
  13. # Disable python support. This disables the 2 following things:
  14. # - wminput Python plugin support
  15. # - cwiid Python module
  16. CWIID_CONF_OPTS = --without-python --disable-ldconfig
  17. ifeq ($(BR2_PACKAGE_CWIID_WMGUI),y)
  18. CWIID_DEPENDENCIES += libgtk2 libglib2
  19. CWIID_CONF_OPTS += --enable-wmgui
  20. else
  21. CWIID_CONF_OPTS += --disable-wmgui
  22. endif
  23. $(eval $(autotools-package))