capnproto.mk 1.0 KB

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # capnproto
  4. #
  5. ################################################################################
  6. CAPNPROTO_VERSION = 0.8.0
  7. CAPNPROTO_SITE = $(call github,capnproto,capnproto,v$(CAPNPROTO_VERSION))
  8. CAPNPROTO_LICENSE = MIT
  9. CAPNPROTO_LICENSE_FILES = LICENSE
  10. CAPNPROTO_INSTALL_STAGING = YES
  11. # Fetched from Github with no configure script
  12. CAPNPROTO_AUTORECONF = YES
  13. CAPNPROTO_CONF_OPTS = --with-external-capnp
  14. # Needs the capnproto compiler on the host to generate C++ code from message
  15. # definitions
  16. CAPNPROTO_DEPENDENCIES = host-autoconf host-capnproto
  17. ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
  18. CAPNPROTO_CONF_ENV += LIBS=-latomic
  19. endif
  20. # The actual source to be compiled is within a 'c++' subdirectory
  21. CAPNPROTO_SUBDIR = c++
  22. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  23. CAPNPROTO_CONF_OPTS += --with-openssl
  24. CAPNPROTO_DEPENDENCIES += openssl
  25. else
  26. CAPNPROTO_CONF_OPTS += --without-openssl
  27. endif
  28. $(eval $(autotools-package))
  29. $(eval $(host-autotools-package))