bootstrap.mk 976 B

123456789101112131415161718192021222324252627
  1. ################################################################################
  2. #
  3. # bootstrap
  4. #
  5. ################################################################################
  6. BOOTSTRAP_VERSION = 4.3.1
  7. BOOTSTRAP_SITE = https://github.com/twbs/bootstrap/releases/download/v$(BOOTSTRAP_VERSION)
  8. BOOTSTRAP_SOURCE = bootstrap-$(BOOTSTRAP_VERSION)-dist.zip
  9. BOOTSTRAP_LICENSE = MIT
  10. BOOTSTRAP_LICENSE_FILES = css/bootstrap.css
  11. define BOOTSTRAP_EXTRACT_CMDS
  12. $(UNZIP) $(BOOTSTRAP_DL_DIR)/$(BOOTSTRAP_SOURCE) -d $(@D)
  13. mv $(@D)/bootstrap-$(BOOTSTRAP_VERSION)-dist/* $(@D)
  14. endef
  15. define BOOTSTRAP_INSTALL_TARGET_CMDS
  16. $(INSTALL) -m 0644 -D $(@D)/css/bootstrap.min.css \
  17. $(TARGET_DIR)/var/www/bootstrap/css/bootstrap.min.css
  18. $(INSTALL) -m 0644 -D $(@D)/css/bootstrap.min.css.map \
  19. $(TARGET_DIR)/var/www/bootstrap/css/bootstrap.min.css.map
  20. $(INSTALL) -m 0644 -D $(@D)/js/bootstrap.min.js \
  21. $(TARGET_DIR)/var/www/bootstrap/js/bootstrap.min.js
  22. endef
  23. $(eval $(generic-package))