bluez-alsa.mk 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. ################################################################################
  2. #
  3. # bluez-alsa
  4. #
  5. ################################################################################
  6. BLUEZ_ALSA_VERSION = 2.1.0
  7. BLUEZ_ALSA_SITE = $(call github,Arkq,bluez-alsa,v$(BLUEZ_ALSA_VERSION))
  8. BLUEZ_ALSA_LICENSE = MIT
  9. BLUEZ_ALSA_LICENSE_FILES = LICENSE
  10. BLUEZ_ALSA_DEPENDENCIES = alsa-lib bluez5_utils libglib2 sbc host-pkgconf
  11. # git repo, no configure
  12. BLUEZ_ALSA_AUTORECONF = YES
  13. BLUEZ_ALSA_CONF_OPTS = \
  14. --enable-aplay \
  15. --disable-debug-time \
  16. --with-alsaplugindir=/usr/lib/alsa-lib \
  17. --with-alsaconfdir=/etc/alsa/conf.d
  18. ifeq ($(BR2_PACKAGE_FDK_AAC),y)
  19. BLUEZ_ALSA_DEPENDENCIES += fdk-aac
  20. BLUEZ_ALSA_CONF_OPTS += --enable-aac
  21. else
  22. BLUEZ_ALSA_CONF_OPTS += --disable-aac
  23. endif
  24. ifeq ($(BR2_PACKAGE_LAME),y)
  25. BLUEZ_ALSA_DEPENDENCIES += lame
  26. BLUEZ_ALSA_CONF_OPTS += --enable-mp3lame
  27. else
  28. BLUEZ_ALSA_CONF_OPTS += --disable-mp3lame
  29. endif
  30. ifeq ($(BR2_PACKAGE_MPG123),y)
  31. BLUEZ_ALSA_DEPENDENCIES += mpg123
  32. BLUEZ_ALSA_CONF_OPTS += --enable-mpg123
  33. else
  34. BLUEZ_ALSA_CONF_OPTS += --disable-mpg123
  35. endif
  36. # no build dependency, disables internal HFP in favor of oFonos HFP profile
  37. ifeq ($(BR2_PACKAGE_OFONO),y)
  38. BLUEZ_ALSA_CONF_OPTS += --enable-ofono
  39. else
  40. BLUEZ_ALSA_CONF_OPTS += --disable-ofono
  41. endif
  42. # no build dependency, enables integration with UPower D-Bus service
  43. ifeq ($(BR2_PACKAGE_UPOWER),y)
  44. BLUEZ_ALSA_CONF_OPTS += --enable-upower
  45. else
  46. BLUEZ_ALSA_CONF_OPTS += --disable-upower
  47. endif
  48. ifeq ($(BR2_PACKAGE_BLUEZ_ALSA_HCITOP),y)
  49. BLUEZ_ALSA_DEPENDENCIES += libbsd ncurses
  50. BLUEZ_ALSA_CONF_OPTS += --enable-hcitop
  51. else
  52. BLUEZ_ALSA_CONF_OPTS += --disable-hcitop
  53. endif
  54. ifeq ($(BR2_PACKAGE_BLUEZ_ALSA_RFCOMM),y)
  55. BLUEZ_ALSA_DEPENDENCIES += readline
  56. BLUEZ_ALSA_CONF_OPTS += --enable-rfcomm
  57. else
  58. BLUEZ_ALSA_CONF_OPTS += --disable-rfcomm
  59. endif
  60. $(eval $(autotools-package))