bitstream.mk 648 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # bitstream
  4. #
  5. ################################################################################
  6. BITSTREAM_VERSION = 1.5
  7. BITSTREAM_SOURCE = bitstream-$(BITSTREAM_VERSION).tar.bz2
  8. BITSTREAM_SITE = https://get.videolan.org/bitstream/$(BITSTREAM_VERSION)
  9. BITSTREAM_LICENSE = MIT
  10. BITSTREAM_LICENSE_FILES = COPYING
  11. # package consists of header files only
  12. BITSTREAM_INSTALL_STAGING = YES
  13. BITSTREAM_INSTALL_TARGET = NO
  14. define BITSTREAM_INSTALL_STAGING_CMDS
  15. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) PREFIX=/usr install
  16. endef
  17. $(eval $(generic-package))