bitcoin.mk 953 B

123456789101112131415161718192021222324252627282930313233343536
  1. ################################################################################
  2. #
  3. # bitcoin
  4. #
  5. ################################################################################
  6. BITCOIN_VERSION = 0.20.1
  7. BITCOIN_SITE = https://bitcoincore.org/bin/bitcoin-core-$(BITCOIN_VERSION)
  8. BITCOIN_AUTORECONF = YES
  9. BITCOIN_LICENSE = MIT
  10. BITCOIN_LICENSE_FILES = COPYING
  11. BITCOIN_DEPENDENCIES = host-pkgconf boost libevent
  12. BITCOIN_MAKE_ENV = BITCOIN_GENBUILD_NO_GIT=1
  13. BITCOIN_CONF_OPTS = \
  14. --disable-bench \
  15. --disable-wallet \
  16. --disable-tests \
  17. --with-boost-libdir=$(STAGING_DIR)/usr/lib/ \
  18. --disable-hardening \
  19. --without-gui
  20. ifeq ($(BR2_PACKAGE_LIBMINIUPNPC),y)
  21. BITCOIN_DEPENDENCIES += libminiupnpc
  22. BITCOIN_CONF_OPTS += --with-miniupnpc
  23. else
  24. BITCOIN_CONF_OPTS += --without-miniupnpc
  25. endif
  26. ifeq ($(BR2_PACKAGE_ZEROMQ),y)
  27. BITCOIN_DEPENDENCIES += zeromq
  28. BITCOIN_CONF_OPTS += --with-zmq
  29. else
  30. BITCOIN_CONF_OPTS += --without-zmq
  31. endif
  32. $(eval $(autotools-package))