bird.mk 1012 B

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # bird
  4. #
  5. ################################################################################
  6. BIRD_VERSION = 2.0.7
  7. BIRD_SITE = ftp://bird.network.cz/pub/bird
  8. BIRD_LICENSE = GPL-2.0+
  9. BIRD_LICENSE_FILES = README
  10. BIRD_DEPENDENCIES = host-flex host-bison
  11. ifeq ($(BR2_PACKAGE_BIRD_CLIENT),y)
  12. BIRD_CONF_OPTS += --enable-client
  13. BIRD_DEPENDENCIES += ncurses readline
  14. else
  15. BIRD_CONF_OPTS += --disable-client
  16. endif
  17. BIRD_PROTOCOLS = \
  18. $(if $(BR2_PACKAGE_BIRD_BFD),bfd) \
  19. $(if $(BR2_PACKAGE_BIRD_BABEL),babel) \
  20. $(if $(BR2_PACKAGE_BIRD_BGP),bgp) \
  21. $(if $(BR2_PACKAGE_BIRD_MRT),mrt) \
  22. $(if $(BR2_PACKAGE_BIRD_OSPF),ospf) \
  23. $(if $(BR2_PACKAGE_BIRD_PERF),perf) \
  24. $(if $(BR2_PACKAGE_BIRD_PIPE),pipe) \
  25. $(if $(BR2_PACKAGE_BIRD_RADV),radv) \
  26. $(if $(BR2_PACKAGE_BIRD_RIP),rip) \
  27. $(if $(BR2_PACKAGE_BIRD_STATIC),static)
  28. BIRD_CONF_OPTS += --with-protocols=$(subst $(space),$(comma),$(strip $(BIRD_PROTOCOLS)))
  29. $(eval $(autotools-package))