bcusdk.mk 876 B

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # bcusdk
  4. #
  5. ################################################################################
  6. BCUSDK_VERSION = 0.0.5
  7. BCUSDK_SOURCE = bcusdk_$(BCUSDK_VERSION).tar.gz
  8. BCUSDK_SITE = http://www.auto.tuwien.ac.at/~mkoegler/eib
  9. BCUSDK_LICENSE = GPL-2.0+
  10. BCUSDK_LICENSE_FILES = COPYING
  11. BCUSDK_INSTALL_STAGING = YES
  12. BCUSDK_CONF_OPTS = \
  13. --enable-onlyeibd \
  14. --enable-ft12 \
  15. --enable-pei16 \
  16. --enable-tpuarts \
  17. --enable-eibnetip \
  18. --enable-eibnetipserver \
  19. --enable-eibnetiptunnel \
  20. --without-pth-test \
  21. --with-pth=$(STAGING_DIR)/usr
  22. BCUSDK_DEPENDENCIES = \
  23. libpthsem \
  24. $(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
  25. define BCUSDK_REMOVE_EXAMPLES
  26. $(RM) -rf $(TARGET_DIR)/usr/share/bcusdk
  27. endef
  28. BCUSDK_POST_INSTALL_TARGET_HOOKS += BCUSDK_REMOVE_EXAMPLES
  29. $(eval $(autotools-package))