autofs.mk 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. ################################################################################
  2. #
  3. # autofs
  4. #
  5. ################################################################################
  6. AUTOFS_VERSION = 5.1.6
  7. AUTOFS_SOURCE = autofs-$(AUTOFS_VERSION).tar.xz
  8. AUTOFS_SITE = $(BR2_KERNEL_MIRROR)/linux/daemons/autofs/v5
  9. AUTOFS_LICENSE = GPL-2.0+
  10. AUTOFS_LICENSE_FILES = COPYING COPYRIGHT
  11. AUTOFS_DEPENDENCIES = host-flex host-bison host-pkgconf host-nfs-utils
  12. # autofs looks on the build machine for the path of modprobe, mount,
  13. # umount and fsck programs so tell it explicitly where they will be
  14. # located on the target.
  15. AUTOFS_CONF_ENV = \
  16. ac_cv_path_E2FSCK=/sbin/fsck \
  17. ac_cv_path_E3FSCK=no \
  18. ac_cv_path_E4FSCK=no \
  19. ac_cv_path_KRB5_CONFIG=no \
  20. ac_cv_path_MODPROBE=/sbin/modprobe \
  21. ac_cv_path_MOUNT=/bin/mount \
  22. ac_cv_path_MOUNT_NFS=/usr/sbin/mount.nfs \
  23. ac_cv_path_UMOUNT=/bin/umount \
  24. ac_cv_linux_procfs=yes
  25. # instead of looking in the PATH like any reasonable package, autofs
  26. # configure looks only in an hardcoded search path for host tools,
  27. # which we have to override with --with-path.
  28. AUTOFS_CONF_OPTS = \
  29. --disable-mount-locking \
  30. --enable-ignore-busy \
  31. --without-openldap \
  32. --without-sasl \
  33. --with-path="$(BR_PATH)" \
  34. --with-hesiod=no
  35. AUTOFS_MAKE_ENV = DONTSTRIP=1
  36. ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
  37. AUTOFS_CONF_OPTS += --with-libtirpc
  38. AUTOFS_DEPENDENCIES += libtirpc
  39. else
  40. AUTOFS_CONF_OPTS += --without-libtirpc
  41. endif
  42. $(eval $(autotools-package))