augeas.mk 677 B

12345678910111213141516171819202122
  1. ################################################################################
  2. #
  3. # augeas
  4. #
  5. ################################################################################
  6. AUGEAS_VERSION = 1.12.0
  7. AUGEAS_SITE = http://download.augeas.net
  8. AUGEAS_INSTALL_STAGING = YES
  9. AUGEAS_LICENSE = LGPL-2.1+
  10. AUGEAS_LICENSE_FILES = COPYING
  11. AUGEAS_DEPENDENCIES = host-pkgconf readline libxml2
  12. AUGEAS_CONF_OPTS = --disable-gnulib-tests
  13. # Remove the test lenses which occupy about 1.4 MB on the target
  14. define AUGEAS_REMOVE_TEST_LENSES
  15. rm -rf $(TARGET_DIR)/usr/share/augeas/lenses/dist/tests
  16. endef
  17. AUGEAS_POST_INSTALL_TARGET_HOOKS += AUGEAS_REMOVE_TEST_LENSES
  18. $(eval $(autotools-package))