audit.mk 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. ################################################################################
  2. #
  3. # audit
  4. #
  5. ################################################################################
  6. AUDIT_VERSION = 2.8.5
  7. AUDIT_SITE = http://people.redhat.com/sgrubb/audit
  8. AUDIT_LICENSE = GPL-2.0+ (programs), LGPL-2.1+ (libraries)
  9. AUDIT_LICENSE_FILES = COPYING COPYING.LIB
  10. # 0002-Add-substitue-functions-for-strndupa-rawmemchr.patch
  11. AUDIT_AUTORECONF = YES
  12. AUDIT_INSTALL_STAGING = YES
  13. AUDIT_CONF_OPTS = --without-python --without-python3 --disable-zos-remote
  14. ifeq ($(BR2_PACKAGE_LIBCAP_NG),y)
  15. AUDIT_DEPENDENCIES += libcap-ng
  16. AUDIT_CONF_OPTS += --with-libcap-ng=yes
  17. else
  18. AUDIT_CONF_OPTS += --with-libcap-ng=no
  19. endif
  20. # For i386, x86-64 and PowerPC, the system call tables are
  21. # unconditionally included. However, for ARM(eb) and AArch64, then
  22. # need to be explicitly enabled.
  23. ifeq ($(BR2_arm)$(BR2_armeb),y)
  24. AUDIT_CONF_OPTS += --with-arm
  25. endif
  26. ifeq ($(BR2_aarch64),y)
  27. AUDIT_CONF_OPTS += --with-aarch64
  28. endif
  29. ifeq ($(BR2_INIT_SYSTEMD),y)
  30. AUDIT_CONF_OPTS += --enable-systemd
  31. else
  32. AUDIT_CONF_OPTS += --disable-systemd
  33. endif
  34. define AUDIT_INSTALL_INIT_SYSV
  35. $(INSTALL) -D -m 755 package/audit/S02auditd $(TARGET_DIR)/etc/init.d/S02auditd
  36. endef
  37. define AUDIT_INSTALL_INIT_SYSTEMD
  38. $(INSTALL) -D -m 644 package/audit/audit_tmpfiles.conf \
  39. $(TARGET_DIR)/usr/lib/tmpfiles.d/audit.conf
  40. endef
  41. define AUDIT_INSTALL_CLEANUP
  42. $(RM) $(TARGET_DIR)/etc/rc.d/init.d/auditd
  43. $(RM) $(TARGET_DIR)/etc/sysconfig/auditd
  44. endef
  45. AUDIT_POST_INSTALL_TARGET_HOOKS += AUDIT_INSTALL_CLEANUP
  46. define AUDIT_LINUX_CONFIG_FIXUPS
  47. $(call KCONFIG_ENABLE_OPT,CONFIG_NET)
  48. $(call KCONFIG_ENABLE_OPT,CONFIG_AUDIT)
  49. endef
  50. HOST_AUDIT_CONF_OPTS = \
  51. --without-python \
  52. --without-python3 \
  53. --disable-zos-remote \
  54. --without-libcap-ng
  55. $(eval $(autotools-package))
  56. $(eval $(host-autotools-package))