aubio.mk 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. ################################################################################
  2. #
  3. # aubio
  4. #
  5. ################################################################################
  6. AUBIO_VERSION = 0.4.9
  7. AUBIO_SITE = https://aubio.org/pub
  8. AUBIO_SOURCE = aubio-$(AUBIO_VERSION).tar.bz2
  9. AUBIO_LICENSE = GPL-3.0+
  10. AUBIO_LICENSE_FILES = COPYING
  11. AUBIO_INSTALL_STAGING = YES
  12. AUBIO_CONF_OPTS = \
  13. --disable-docs \
  14. --disable-atlas
  15. # Add --notests for each build step to avoid running unit tests on the
  16. # build machine.
  17. AUBIO_WAF_OPTS = --notests
  18. ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
  19. AUBIO_DEPENDENCIES += libsndfile
  20. AUBIO_CONF_OPTS += --enable-sndfile
  21. else
  22. AUBIO_CONF_OPTS += --disable-sndfile
  23. endif
  24. # Could not compile aubio in double precision mode with libsamplerate
  25. ifeq ($(BR2_PACKAGE_LIBSAMPLERATE):$(BR2_PACKAGE_FFTW_DOUBLE),y:)
  26. AUBIO_DEPENDENCIES += libsamplerate
  27. AUBIO_CONF_OPTS += --enable-samplerate
  28. else
  29. AUBIO_CONF_OPTS += --disable-samplerate
  30. endif
  31. ifeq ($(BR2_PACKAGE_JACK2),y)
  32. AUBIO_DEPENDENCIES += jack2
  33. AUBIO_CONF_OPTS += --enable-jack
  34. else
  35. AUBIO_CONF_OPTS += --disable-jack
  36. endif
  37. # fftw3 require double otherwise it will look for fftw3f
  38. ifeq ($(BR2_PACKAGE_FFTW_DOUBLE),y)
  39. AUBIO_CONF_OPTS += --enable-fftw3 --enable-double
  40. AUBIO_DEPENDENCIES += fftw-double
  41. else ifeq ($(BR2_PACKAGE_FFTW_SINGLE),y)
  42. AUBIO_CONF_OPTS += --enable-fftw3f --disable-double
  43. AUBIO_DEPENDENCIES += fftw-single
  44. else
  45. AUBIO_CONF_OPTS += --disable-fftw3
  46. endif
  47. ifeq ($(BR2_PACKAGE_FFMPEG_AVRESAMPLE),y)
  48. AUBIO_DEPENDENCIES += ffmpeg
  49. AUBIO_CONF_OPTS += --enable-avcodec
  50. else
  51. AUBIO_CONF_OPTS += --disable-avcodec
  52. endif
  53. $(eval $(waf-package))